Support » Plugin: Tip Jar WP » Payment Issues

  • Resolved bootsnbourbon

    (@bootsnbourbon)


    Hello there,

    I am having issues with all payments failing, whether in test mode or live mode.

    I have completed the setup wizard, and have got green ticks for everything, showing that everything is healthy, however the payments just don’t go through.

    Please can you help me to fix this issue?

    I’ve noticed that my live modes and test modes are connected to different accounts, even though when I go to the setup screen, I am logged into stripe with the same email address..

    Also, is there anyway to style the popup donation form? I’d like to change the colour of the “pay now” button, and the grey background too.

    Kind Regards,
    Christopher Tutton

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Tip Jar WP

    (@tipjarwp)

    Hey there,

    The first thing I would recommend is disconnecting from Stripe in both live and test mode, which you can do in your WordPress dashboard under “Tip Jar WP” > “Stripe Settings”.

    Once both are disconnected, reconnect both again.

    Then try processing a test payment with Test Mode enabled (under “Tip Jar WP” > “Stripe Settings” > “Test Mode”.

    You can use this test card:

    4242424242424242
    12/34
    123

    If that doesn’t fix it, try temporarily deactivating all 3rd party plugins, just to see if one is causing a conflict.

    If that still doesn’t allow payments to go through, email us at support@tipjarwp.com and we can log into your site to help find what might be going wrong there.

    Thread Starter bootsnbourbon

    (@bootsnbourbon)

    Hello,

    Thank you. I’ll try this tonight.

    Does it matter what address or name I use for the test card?

    Regards,
    Chris

    Plugin Author Tip Jar WP

    (@tipjarwp)

    Just wanting to follow up here to share the problem and solution. The issue was that an apostrophe was included for the card statement descriptor, but apostrophes cannot be accepted by Stripe for card statement descriptors.

    For anyone else experience this today, the solution is to make sure your statement descriptor does not have an apostrophe. In the next update to Tip Jar WP, it will automatically strip out any characters that Stripe does not accept for the card statement descriptor.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Payment Issues’ is closed to new replies.