Support » Plugin: External Links - nofollow, noopener & new window » payment gateway infinite load time

  • Resolved mercurydan

    (@mercurydan)


    It made paying impossible for customers just before entering credit card details in the checkout page for woocommerce.
    The part of the checkout that gives you your order summary just before choosing payment method and change shipping address link.
    I had “follow” on all internal and external links

    WP url:
    WP version: 5.2.2
    PHP version: 7.2.20
    Active Plugins:
    – Akismet Anti-Spam, version: 4.1.2
    – Braintree For WooCommerce, version: 2.6.65
    – EWWW Image Optimizer, version: 4.9.1
    – Health Check & Troubleshooting, version: 1.4.0
    – Heartbeat Control, version: 1.2.5
    – Product GTIN (EAN, UPC, ISBN) for WooCommerce, version: 1.0.5
    – Recover Abandoned Cart, version: 19.6
    – Search & Replace, version: 3.2.1
    – SG Optimizer, version: 5.2.4
    – Thrive Product Manager, version: 1.2.1
    – Thrive Quiz Builder, version: 2.2.1.1
    – Ultimate Addons for Elementor, version: 1.15.0
    – UpdraftPlus – Backup/Restore, version: 1.16.16
    – WooCommerce, version: 3.7.0
    – WooCommerce Advanced Shipping, version: 1.0.13
    – WooCommerce PDF Invoices & Packing Slips, version: 2.3.1
    – WooCommerce Print Invoice & Delivery Note, version: 4.4.8
    – WooCommerce Sendinblue Newsletter Subscription, version: 1.2.14
    – WooCommerce Shop as Customer, version: 2.16
    – WooCommerce Weight Based Shipping, version: 5.3.2
    – WooCommerce Wholesale Prices, version: 1.10
    – WooCommerce Wholesale Prices Premium, version: 1.17
    – WooCommerce Zoho CRM Integration, version: 2.2
    – Wordfence Security, version: 7.3.6
    – WP-Optimize – Clean, Compress, Cache, version: 3.0.11
    – WPC Product Bundles for WooCommerce, version: 3.7.0
    – WP External Links, version: 2.32
    – WPSSO Core (Premium), version: 5.5.3
    – WPSSO Inherit Parent Meta, version: 2.0.1
    – WPSSO Ratings and Reviews, version: 2.2.1
    – WPSSO REST API, version: 2.0.2
    – WPSSO Schema Breadcrumbs Markup, version: 2.1.1
    – WPSSO Schema JSON-LD Markup (Premium), version: 2.6.2
    – WPSSO Strip Schema Microdata, version: 2.0.1
    – WPSSO Tune WP Image Editors, version: 2.0.1
    – WPSSO Update Manager, version: 2.1.1
    – WP Store Locator, version: 2.2.23
    – Yoast SEO, version: 11.8

    WPEL Settings:
    array(
    ‘wpel-external-link-settings’ => array (
    ‘apply_settings’ => ‘1’,
    ‘target’ => ‘_blank’,
    ‘target_overwrite’ => ”,
    ‘rel_follow’ => ‘follow’,
    ‘rel_follow_overwrite’ => ”,
    ‘rel_noopener’ => ‘1’,
    ‘rel_noreferrer’ => ‘1’,
    ‘rel_external’ => ‘1’,
    ‘title’ => ‘{title}’,
    ‘class’ => ”,
    ‘icon_type’ => ”,
    ‘icon_image’ => ‘1’,
    ‘icon_dashicon’ => ‘dashicons-menu’,
    ‘icon_fontawesome’ => ‘fa-500px’,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ‘1’,
    ),
    ‘wpel-internal-link-settings’ => array (
    ‘apply_settings’ => ‘1’,
    ‘target’ => ‘_blank’,
    ‘target_overwrite’ => ‘1’,
    ‘rel_follow’ => ‘follow’,
    ‘rel_follow_overwrite’ => ”,
    ‘rel_noopener’ => ‘1’,
    ‘rel_noreferrer’ => ‘1’,
    ‘title’ => ‘{title}’,
    ‘class’ => ”,
    ‘icon_type’ => ‘dashicon’,
    ‘icon_image’ => ‘1’,
    ‘icon_dashicon’ => ‘dashicons-admin-links’,
    ‘icon_fontawesome’ => ‘fa-500px’,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ”,
    ),
    ‘wpel-excluded-link-settings’ => array (
    ‘apply_settings’ => ”,
    ‘target’ => ”,
    ‘target_overwrite’ => ”,
    ‘rel_follow’ => ”,
    ‘rel_follow_overwrite’ => ”,
    ‘rel_noopener’ => ‘1’,
    ‘rel_noreferrer’ => ‘1’,
    ‘title’ => ‘{title}’,
    ‘class’ => ”,
    ‘icon_type’ => ”,
    ‘icon_image’ => ‘1’,
    ‘icon_dashicon’ => ”,
    ‘icon_fontawesome’ => ”,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ‘1’,
    ),
    ‘wpel-exceptions-settings’ => array (
    ‘apply_all’ => ‘1’,
    ‘apply_post_content’ => ‘1’,
    ‘apply_comments’ => ‘1’,
    ‘apply_widgets’ => ‘1’,
    ‘skip_post_ids’ => ”,
    ‘ignore_classes’ => ”,
    ‘subdomains_as_internal_links’ => ”,
    ‘include_urls’ => ”,
    ‘exclude_urls’ => ”,
    ‘excludes_as_internal_links’ => ”,
    ‘ignore_script_tags’ => ‘1’,
    ‘ignore_mailto_links’ => ‘1’,
    ),
    ‘wpel-admin-settings’ => array (
    ‘own_admin_menu’ => ‘1’,
    ),
    );

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Alexandru Tapuleasa

    (@talextech)

    We are looking into the issue and will get back to you ASAP!

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @lkoudal @talextech @webfactory @underconstructionpage @googlemapswidget @securityninja @wpreset I’ve deleted your offer to login to your user’s site. I’m am 100% sure you mean well but please never ask for credentials. I have flagged your account temporarily. That just means that your post will need to be approved and @ notifications from you will not work.

    https://wordpress.org/support/guidelines/#the-bad-stuff

    Now for the why: The internet is a wonderful place full of very nice people and a few very bad ones. I’m sure everyone here is very nice however, by giving some ones keys to your house you are trusting they wont steal anything. Likewise the person who takes the keys is now responsible for the house FOREVER.

    If something was to go wrong, then you the author may well legally become liable for damages, which they would not normally have been as their software is provided without warranty.

    Please be aware that repeatedly asking for credentials will result in us asking you to repeatedly stop before escalating up to the plugins team.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.