Support » Plugins » Payfast plugin causing white screen of death

  • Hi there,

    I am new to wordpress and trying to build an ecommerce site. I need to use payfast as a payment gateway as it’s the only one I know of that supports South African Rands. The problem is that when I try to activate the plugin it causes the admin site to go completely blank and when I remove it again via ftp the site works again just fine.

    How can I get it to work?

    Please Help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi,

    I have the exact same problem with the same plugin. It was working perfectly before I updated WooCommerce. I’ve tried to delete it and re-install it but I keep getting the white screen of death. I’ve contacted WooCommerce but they say its a free plugin so they do not offer support. Very frustrating!

    Also followed their troubleshooting guide but didn’t help at all.

    I also tried WordPress default theme but the error persists (so we know it’s not a theme conflict/issue.

    Is there anyone out there with suggestions?


    Hi all,

    We’re exploring this further on our end and will revert with feedback soonest.

    Thanks and regards,

    Hi all,

    We’ve deployed version 1.2.9 which resolves this issue.

    Please upgrade via FTP if you encounter the white screen, and advise if the issue persists.

    I’m really sorry for the inconvenience caused here.

    Thanks in advance!

    Thanx Matty, all seems fine on my side now – running 1.2.9

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Payfast plugin causing white screen of death’ is closed to new replies.