Support » Plugin: WooCommerce PayPal Payments » Pay in 3 option does not generate an order and does not work

  • First of all I’ve enabled instant payments so i wonder why PayPal still try to process “Pay in 3 options”.

    I’ve got 2 people claiming to have paid but in the end:
    – WC does not create an order for the transaction
    – I’ve not track of what happened in my Paypal account too
    – The user can see the transaction in a “non completed” status on his side

    Is there any settings i can tweak?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Inpsyde Niklas

    (@niklasinpsyde)

    Hi @antoniogallo,

    If you enable the Require Instant Payment setting, PayPal will be instructed not to allow the buyer to use funding sources that take additional time to complete (for example, eChecks). Instead, the buyer will be required to use an instant funding source, such as an instant transfer, a credit/debit card, or Pay Later.

    With Pay Later, the merchant gets paid instantly by PayPal. Only the buyer has more time to pay back the money PayPal has already given you.

    The Pay Later button can be disabled with the Disable funding sources setting if you don’t wish to provide this option. There shouldn’t be any instances where a Pay Later payment results in no WooCommerce order being created though. Did you have logging enabled during the time of these orders?
    Thanks!

    Kind regards,
    Niklas

    Thread Starter Antonio Gallo

    (@antoniogallo)

    @niklasinpsyde Hi! Yes i’ve enabled “Require Instant Payment” and of course there is no “Pay later” button on the checkout, only Pay now.

    However once the customers logins into paypal
    there is a new option “Pay in 3 installments”

    Please see the image at:
    https://imgur.com/8b1X9KZ

    If they chose that one then the problem mentioned before arise.

    Plugin Support Inpsyde Niklas

    (@niklasinpsyde)

    Hi @antoniogallo,

    Thanks for the additional info.
    When you hide Pay Later with the abovementioned Disable funding sources setting, then this option should also be hidden from the PayPal popup window. Could you please check?
    Anyway, I am pretty sure that this option has been tested thoroughly in the past, but we will look into this closer and run a few tests.

    Kind regards,
    Niklas

    Thread Starter Antonio Gallo

    (@antoniogallo)

    Hi @niklasinpsyde
    I’ve those settings:

    • Instant payments: checked
    • Disable funding sources: Credit or debit cards, sofort, pay later

    If you look at the screenshot paypal says that this thing is “NEW”.

    Plugin Support Inpsyde Niklas

    (@niklasinpsyde)

    Hi @antoniogallo,

    To my knowledge, the option for this funding method should be gone from the popup window as well when it was selected under “Disable funding sources”. We’d like to look into this further in any case.

    Could you please send us a message from here with a copy of your WooCommerce system report?:
    https://paypal.inpsyde.com/docs/request-support/
    Please also include a link to this thread so we can keep it updated.
    Thanks!

    Kind regards,
    Niklas

    Thread Starter Antonio Gallo

    (@antoniogallo)

    @niklasinpsyde I just submitted the form! Thank you 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Pay in 3 option does not generate an order and does not work’ is closed to new replies.