WordPress.org

Forums

[resolved] patterns vanished (13 posts)

  1. thob
    Member
    Posted 3 years ago #

    after the latest update backgrounds vanished. I select them, save but on the front end I get nothing. any idea what I'm missing

    <style type="text/css">
    body.custom-background { background-image: url('http://weber.ir/patterns/patterns/soft_circle_scales.png'); background-repeat: repeat; background-position: top left; background-attachment: scroll; }
    </style>
    is loaded

    Thanks

  2. shazdeh
    Member
    Posted 3 years ago #

    I think the problem is that your theme does not uses body_class function. But, this should be fixed in 2.1. Please update the plugin and see if the problem still exists.

  3. thob
    Member
    Posted 3 years ago #

    I still have the problem. It's maybe related to my theme I'm using Tarski and in the header is <body id="<?php tarski_bodyid(); ?>" class="<?php tarski_bodyclass(); ?>">

    Anything I need to change or add?

  4. shazdeh
    Member
    Posted 3 years ago #

    Tarski supports Custom Backgrounds, and it's working fine for me.
    Could I have the address of your webpage?

  5. thob
    Member
    Posted 3 years ago #

  6. shazdeh
    Member
    Posted 3 years ago #

    In Tarski 3.1.2 in theme repository, the tarski_bodyclass function is replaced with WP's body_class. Your theme is 3.1.2 but it's using the old function, so if you replace it, it should work fine.
    Please let me know if it worked!

  7. thob
    Member
    Posted 3 years ago #

    excellent!. it's working now. I was using a child theme with an extra header that didn't reflect this change.

    Thanks!

  8. shazdeh
    Member
    Posted 3 years ago #

    Glad that it's working.
    Have fun!

  9. givesuccess
    Member
    Posted 3 years ago #

    Today I noticed my chosen background has vanished. When i try to put it back in settings popup in get this error:

    Warning: file_get_contents(http://weber.ir/patterns/count.php) [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /var/www/vhosts/abiznow.com/ant/wp-content/plugins/bg-patterns/options.php on line 66

    Let me know if anyone else has or knows how to fix...thnx

  10. shazdeh
    Member
    Posted 3 years ago #

    Yeah, sorry about that. Since yesterday my whole web server has broken for an unknown reason. I'm hoping it will be fixed in the next few days. If it didn't, I'll find a publicly available server and update the plugin.
    Do you know a free server I could upload all the patterns?

  11. givesuccess
    Member
    Posted 3 years ago #

    I figured as much when i tried to get to the url it said not found.

    I have used these 2 free host in past:

    http://www.000webhost.com/
    http://www.freehostia.com/

    They are free so they might not be too dependable or might have some stuff "turned off". The 1st one is prob your first choice to try bc 2nd is more restrictive as free.

    I will try it in a week or so. For now i deactivated the plugin for now.

  12. shazdeh
    Member
    Posted 3 years ago #

    The problem was fixed about 10 hours ago. It's working fine now.
    Thanks, I'll try those and see if they work out.

  13. givesuccess
    Member
    Posted 3 years ago #

    glad to hear...thnx

Topic Closed

This topic has been closed to new replies.

About this Topic