Support » Fixing WordPress » PATHINFO permalinks won’t change successfully to “Pretty” permalinks

  • This was a previous issue,

    I am currently using “almost-pretty permalinks”: /index.php/%category%/%postname%/%post_id%
    It works fine and dandy.

    I want to switch to completely pretty permalinks by removing the /index.php part

    I am having the exact same problem, when I change the permalinks structure on my WordPress settings to a “Pretty” format, all the links to pages are updated but when clicked they give a 404 not found error.

    The solution that was suggested has not worked for me. My blog is http://www.sixfiftyseven.co.uk and is hosted at sixfiftyseven.uuuq.com.

    Can anybody give me some insight as to why this would not work for me? I have a writeable .htaccess file. I am not an expert and this problem is driving me crazy, I just can’t see what I have done wrong.

    Thanks,
    Rob

Viewing 7 replies - 1 through 7 (of 7 total)
  • in admin – settings
    do you have the index.php removed from the 2 url’s?

    They have always been as:

    WordPress Address (URL): http://sixfiftyseven.co.uk

    Blog Address (URL): http://sixfiftyseven.co.uk

    Any help will be much appreciated.
    Rob

    so you are redirecting?
    likely the problem

    What could I change to allow both “Pretty” permalinks and the custom domain name to work?

    I’m sure I can’t be the only person who has wanted to do this.

    Thanks,
    Rob

    Some hosts (like Yahoo) force the index.php in there for reasons unknown to me. Who’s your webhost?

    I used to be with “DreamHost” but I made the site more minimal and moved to a free host “Zymic”.

    The wordpress site is now with “Zymic” under a subdomain uuuq.com.

    So is redirecting a common cause of this problem?

    From what I’ve read a lot of people find the same 404 not found messages when trying to use “Pretty” permalinks.

    Any info is appreciated, I don’t know a lot about this stuff.

    Thanks,
    Rob

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘PATHINFO permalinks won’t change successfully to “Pretty” permalinks’ is closed to new replies.