Support » Plugin: Polldaddy Polls & Ratings » Patch to fix PHP notice

  • Simon Wheatley

    (@simonwheatley)


    Code for the People

    Hi,

    I noticed a PHP notice (ahem) while trying out Polldaddy, and as it’s easily fixed, here’s a patch…

    Cheers,

    Simon

    Index: polldaddy.php
    ===================================================================
    --- polldaddy.php	(revision 625777)
    +++ polldaddy.php	(working copy)
    @@ -1833,7 +1833,7 @@
     					</td>
     					<td class="answer-media-icons" <?php echo isset( $_GET['iframe'] ) ? 'style="width: 55px !important;"' : '';?>>
     					<ul class="answer-media" <?php echo isset( $_GET['iframe'] ) ? 'style="min-width: 30px;"' : '';?>>
    -<?php  if ( $mediaType[999999999] == 2 ) { ?>
    +<?php  if ( isset( $mediaType[999999999] ) && $mediaType[999999999] == 2 ) { ?>
     				<li class="media-preview" style="width: 20px; height: 16px; padding-left: 5px;"><img height="16" width="16" src="<?php echo plugins_url( 'img/icon-report-ip-analysis', __FILE__ ); ?>" alt="Video Embed"></li>
     <?php   } else { ?>
     				<li class="media-preview" style="width: 20px; height: 16px; padding-left: 5px;"><?php

    http://wordpress.org/extend/plugins/polldaddy/

  • The topic ‘Patch to fix PHP notice’ is closed to new replies.