Support » Plugin: The Events Calendar Shortcode & Block » […past=’yes’] doesn’t hide past events and other issues

  • Events Calendar: 5.1.6
    Events Calendar Shortcode & Block: 2.4
    Theme: Divi 4.6.1

    PROBLEMS:
    The past events (i.e., March, April, May, etc.) are still displaying.
    Venue is not displaying.

    I’m using the following shortcode:
    [ecs-list-events limit=’100′ order=’ASC’ venue=’true’ past=’no’]

    Anywhere I’m going wrong?
    Thank you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Brian Hogg

    (@brianhogg)

    Hi @toad78 !

    Have you tried re-typing the shortcode? It looks like you might have a couple “special” quotes in there, which might be part of the issue. More detail on our common issues article here (number 2):

    https://eventcalendarnewsletter.com/how-to-fix-the-events-calendar-shortcode-not-working/

    You can also skip putting the past parameter at all, since it should only show future events by default.

    Cheers!

    I redeveloped the shortcode and have the same result: the past events are still showing.
    Even if I remove the ‘past’ perimeter, the past events still display.

    Plugin Author Brian Hogg

    (@brianhogg)

    Hi @toad78 !

    In this case, the theme or another plugin on the site may be forcing past events to be shown. You can determine which plugin or theme is causing the issue with the following steps:

    1. Ensure you have a backup of your site in case there are any issues when disabling/enabling plugins or your theme
    2. Disable all plugins (except The Events Calendar plugin and this plugin), and switch to a default theme like Twenty Twenty, then verify the issue is resolved
    3. Re-enable your plugins and switch back to your previous theme one by one verifying if the issue is still occurring, and note which one causes it to break

    Let me know which plugin/theme causes the issue as I may be able to come up with a workaround, but most likely you’ll also need to contact the theme or plugin author and have them fix the issue.

    Cheers!

    I’ll take a look.

    Thank you for the suggestions, Brian.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.