WordPress.org

Forums

Pasting footnotes from MS Word doesn't create html links (1 post)

  1. kaboomki
    Member
    Posted 9 months ago #

    Hi, when I am pasting a short text from a word document with footnotes in the wordpress installation (german) on my server I get the following result:

    Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum.[1] Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum.[2].
     
    [1] This is footnote 1
    [2] This is footnote 2

    Pasting the same text on WordPress.com or on the TinyMCE testbed I receive the following result:

    Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum.<a href="#_ftn1" name="_ftnref1">[1]</a> Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum.<a href="#_ftn2" name="_ftnref2">[2]</a>
    &nbsp;
    <a href="#_ftnref1" name="_ftn1">[1]</a> This is footnote 1
    <a href="#_ftnref2" name="_ftn2">[2]</a> This is footnote 2

    Links to footnotes are automatically generated when pasting. This has worked before and I guess it is related to the reworking of the tinyMCI visual editor. I followed the instructions to troubleshoot and dectivated all plugins and switched to the 2014 theme. However I couldn't get the old automatic formatting of pasted footnotes running again. Since we publish a lot of academic papers this behaviour is very much missed by our editors. Any ideas how to enable this useful feature again?

    Thanks
    Karsten

Reply

You must log in to post.

About this Topic