• Resolved lozula

    (@lozula)


    When I have a long post with images inserted from the media library, pasting content into it causes the editor to jump.

    Example, I paste text at the top of the page, and I get transported to the middle of the page.

    If I disable “Enable full-height editor and distraction-free functionality” the issue goes away.

    It was also an issue on Classic Editor, so I switched over to see if this plugin would resolve it (looks like a better plugin anyway!), but it has the same behaviour. You can see the discussion about Classic Editor here:

    https://wordpress.org/support/topic/wordpress-classic-editor-paste-page-auto-scroll-down/

    I’ve fully removed Classic Editor, cleared all the caches etc, but am experincing the same behaviour with Disable Gutenberg.

    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jeff Starr

    (@specialk)

    Glad to help. Actually what you describe is a bug with the editor itself, not any “disable-gutenberg” type plugin. Plugins like DG and CE simply enable the existing editor scripts provided by WordPress core. Think of DG/CE like a toggle switch: when enabled, the WP core classic-editor scripts are loaded; or when disabled, the block scripts are loaded. That’s all the plugins are doing. The actual editor scripts may have bugs, but not something that can be fixed via DG/CE.

    I hope that explains it. Let me know if I can elaborate or provide any further infos.

    Thread Starter lozula

    (@lozula)

    That makes perfect sense, and thanks for the very swift reply. I think I will stick with this plugin just on that basis 🙂

    Do you happen to know if this is a known issue that’s being worked on, or should I file a bug in the wordpress bug tracker? I’m just not sure if they’d care if it only affects the old way of doing things 😉

    Plugin Author Jeff Starr

    (@specialk)

    You are welcome, @lozula 🙂 And yeah you might try a bug report, although like you say the focus now is on the new JavaScript/block stuff. Another possibility, it could be a browser-related issue. Have you tried the editor/jumping in different browsers?

    Thread Starter lozula

    (@lozula)

    Good idea 🙂 I tried it in Firefox as well as Chrome & Edge and it gives the same result. Ah well. Hopefully it’s fixed at some point.

    Plugin Author Jeff Starr

    (@specialk)

    That’s good to know, thanks @lozula. Also thank you for the great review 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Paste causes screen jump’ is closed to new replies.