Support » Plugin: The Events Calendar Shortcode & Block » Past events works for 2011 & 2013 but not 2012 or 2014!

  • I am running on LocalHost/WAMPP/Windows 10, Theme Satisfy 1.0.8/The Events Calendar 4.5.10/Events Calendar Shortcode 1.6.1.
    Past Events works fine for years 2011, 2013, 2015, 2016, 2017. But years 2012 & 2014 produce the following:
    “There are no upcoming events at this time.’’ I have screenshots for
    Edit/EventsCategory, for both years, both have “Past concerts” as events category and year as name and slug.
    “Edit Page is also the same for both years (except for date):
    Click on concert name for details:
    [ecs-list-events past=’yes’ cat=2012 order=’DESC’ limit=20]”
    I had originally written pages for years “2011-12” and “2013-14” and then changed them to separate pages for the individual years. Could this have made a difference?
    We are almost ready to go online with this website, which would include an upgrade to Events Calendar Shortcode Pro version. But we cannot consider an upgrade if the original version doesn’t work. Please help me solve this strange problem! Thank you! Could it have to do with Permalinks, and can they be edited? They all read: …wordpress/past-concerts/2011-2/ (with only the year changing, i.e. 2011-2/, etc.) Let me know how I can send you screenshots as I obviously can’t send URL. The -2 was added when I deleted the original 2011-12 and 2013-14 pages. Pages 2015, 2016, & 2017 don’t have it.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Brian Hogg

    (@brianhogg)

    Hi @ncbogroupie!

    If you are using categories to split the years, can you try adding quotes around the category name? For example:

    [ecs-list-events past='yes' cat='2011-2' order='DESC' limit='20']

    Make sure to type out the quotes so they are not the “slanted” quotes that will not work.

    The pro version also includes the year option so you could just put year='2012' and not worry about the category slugs:

    https://eventcalendarnewsletter.com/the-events-calendar-shortcode/

    Hope that helps!

    Thanks, Brian, but it didn’t work! We will probably go for the pro version when we go online…Hopefully soon! and that will solve one problem. I have another problem which I think is a conflict between my theme Satisfy and The Events Calendar (not ECSC). Will have to resolve that before we’re ready to go online.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Past events works for 2011 & 2013 but not 2012 or 2014!’ is closed to new replies.