Support » Plugin: Event Organiser » Past Events are still showing on Calendars

  • Hi
    I am hoping someone can offers assistance on this matter

    I am using a calendar on my front page – but I am unable to set this calendar not to show past events.

    I have tried

    <?php echo do_shortcode( '[eo_fullcalendar headerLeft="" headerCenter="title" event_start_after="now"]' ); ?>
    
    <?php echo do_shortcode( '[eo_fullcalendar headerLeft="" headerCenter="title" showpastevents="false"]' ); ?>
    
    <?php echo do_shortcode( '[eo_fullcalendar headerLeft="" headerCenter="title" event_start_after="now" showpastevents="false"]' ); ?>

    I have also ensured that the Events Organiser settings – tick box for showing past events is not ticked.

    Any help appreciated.

    Many Thanks
    Brad

    https://wordpress.org/plugins/event-organiser/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Stephen Harris

    (@stephenharris)

    Hi Brad,

    Those attributes are not supported by the calendar, and nor does that setting apply to the calendar. It applies to the Events pages.

    Calendars display past events, and there isn’t the option to disable that behaviour unfortunately. You can opt to delete events automatically (about 24 hours after their last occurrence finishes).

    Hi Stephen

    Thank you for your reply – greatly appreciated.

    Yes I have enabled delete events automatically – which works for one off events – Is there a way to remove recurring events from the calendar once actual date of an instance has passed?

    May I ask if you know of any third party calendars that work with your great plugin and allow display control of expired events?

    Kind Regards
    Brad

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Past Events are still showing on Calendars’ is closed to new replies.