Support » Plugin: The Events Calendar Shortcode & Block » Past Event List Ascending Order

  • Resolved juliammills

    (@juliammills)


    I have the following code in the Code Block on the page:

    [ecs-list-events cat=”free webinars” limit=100 order=desc past=yes eventdetails=false]

    And this is the default code in the-events-calendar-shortcode.php:

    $atts = shortcode_atts( apply_filters( ‘ecs_shortcode_atts’, array(
    ‘cat’ => ”,
    ‘month’ => ”,
    ‘limit’ => 5,
    ‘eventdetails’ => ‘true’,
    ‘time’ => null,
    ‘past’ => null,
    ‘venue’ => ‘false’,
    ‘author’ => null,
    ‘schema’ => ‘true’,
    ‘message’ => ‘There are no upcoming %s at this time.’,
    ‘key’ => ‘End Date’,
    ‘order’ => ‘DESC’,
    ‘orderby’ => ‘startdate’,
    ‘viewall’ => ‘false’,
    ‘excerpt’ => ‘false’,
    ‘thumb’ => ‘false’,
    ‘thumbsize’ => ”,
    ‘thumbwidth’ => ”,
    ‘thumbheight’ => ”,
    ‘contentorder’ => apply_filters( ‘ecs_default_contentorder’, ‘title, thumbnail, excerpt, date, venue’, $atts ),
    ‘event_tax’ => ”,
    ), $atts ), $atts, ‘ecs-list-events’ );

    But on the page in question, the events are still showing in ascending order.

    Can you please let me know if there is another spot I should be looking for a setting that is overriding the default and the code block code?

    Thank you!

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Brian Hogg

    (@brianhogg)

    Hi @juliammills !

    There was an issue ordering in descending order since a recent version of The Events Calendar (by Modern Tribe) came out. If you update to version 2.3 that should resolve the issue, let me know if not!

    Note that any customizations you made to the plugin would be erased when you update. You can instead use hooks and filters where possible in a functional plugin.

    Cheers!

    Hi Brian,

    That worked! The 2.3 update became available today and the descending order is working again.

    Thank you so much for your help!

    Plugin Author Brian Hogg

    (@brianhogg)

    Hi @juliammills ,

    No problem at all, glad that did the trick!

    If you’re happy with the support and wouldn’t mind leaving a review, it would be appreciated 🙂

    Cheers!

    • This reply was modified 2 months, 1 week ago by Jan Dembowski. Reason: Deleted ?filter=5 from review link
    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @brianhogg Don’t put ?filter=5 in your review links. That’s not necessary as the stars default to 5 for all new reviews and doing that is gaming the impression of people who you ask for reviews.

    I’ve removed that part and now they’ll see the actual reviews and not just the 5 star ones.

    Plugin Author Brian Hogg

    (@brianhogg)

    Sorry about that @jdembowski, thanks for the correction/edit!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.