Support » Plugin: Better Notifications for WP » Password shortcode problem

  • Resolved velitra

    (@velitra)


    Hey!

    I use notification plugin and it has been working well. Something happened and now [password_url] shortcode dosen´t work anymore. When you press password link it says that it´s broken. In same notification i have [email_user_login] shortcode and that works just fine. Could someone help me with this issue?

    Thanks
    Veli-Matti

Viewing 15 replies - 16 through 30 (of 31 total)
  • Plugin Author bnfw

    (@voltronik)

    @aggk @velitra Another couple of questions:

    – Did you try in single site or WordPress Multisite?
    – Is the wp_generate_password function or the random_password filters overridden by either a plugin or custom code?
    – Are there any special constants set in the wp-config.php file regarding encryption?

    -I´m using Single site only
    -No custom code/plugin
    -Nothing extra in wp-config.php that I´m aware of, what should I look out for?

    Have this on a staging install now with nothing but latest WordPress + BNFW

    Thanks!

    Plugin Author bnfw

    (@voltronik)

    Hi @aggk,
    Thanks.

    Is the staging site using the default Twenty Twenty theme? Have you tested it with just WordPress + BNFW + Twenty Twenty?

    Yes, I have only latest WordPress + default theme and BNFW here

    Thanks!

    Plugin Author bnfw

    (@voltronik)

    Thanks @aggk,
    I’ll continue to test. Still having difficulty re-creating the issue at the moment. I’ll let you know if I find anything though.

    Hi

    I experience the same issue.

    For me [password_url] just returns blank in the mail. So it seems like it renders the shortcode but don’t return a value (the link for setting the password).

    The trigger is ‘New User – Post-registration Email’

    I’m also on WordPress 5.3.2

    Plugin Author bnfw

    (@voltronik)

    Hi @markbuskbjerg,
    The ‘New User – Post-registration Email’ can’t use the [password_url] shortcode. This shortcode can only be used by the New User Registration - For User.

    Plugin Author bnfw

    (@voltronik)

    HI @markbuskbjerg @velitra,
    Can you tell me what host you’re on? Trying to pinpoint if the issue is specifically on WP Engine (or hosts that use the same configuration). At time of writing, it does appear that there is an issue when the plugin is used on WP Engine which WP Engine are investigating.

    I’m on UnoEuro.

    I think I’ve discovered my problem to be with generating a user through Gravity Forms User Add-On plugin. It has it own settings for whether or not emails should be sent. So I had to do everything through those settings instead.

    So it was probably just those settings overriding the settings in your plugin.

    I’m on Danish Based hosting: Unoeuro.com

    Plugin Author bnfw

    (@voltronik)

    Hi @markbuskbjerg,
    Ok, thanks for the update.

    Yes, the GF User Registration Add-on is mostly likely the issue in your circumstance.

    Im having the same issue, after registering, I receive the email but the set password shortcode is not working. It just displays the shortcode but not the link.

    The username shortcode works fine.

    See screenshot -> https://imgur.com/a/1NbFAs2

    Can you please advise?

    Thanks…

    Plugin Author bnfw

    (@voltronik)

    Hi @karll10,
    Which notification are you using in BNFW?

    Hey,

    Im using the New User Registration – For Admin notification…

    I have just enabled it for user aswell and the password link displays but is there any way to change the default from email address?

    See attached screenshot -> https://imgur.com/a/65VJi85

    Plugin Author bnfw

    (@voltronik)

    Hi @karll10,
    Ah, that’s the issue – the Admin notification can’t use that shortcode.
    You can change the default from email and user but it comes with some caveats. Details here: https://betternotificationsforwp.com/documentation/compatibility/changing-name-email-transactional-notifications/

Viewing 15 replies - 16 through 30 (of 31 total)
  • You must be logged in to reply to this topic.