Support » Plugin: Better Notifications for WP » Password shortcode problem

  • Resolved velitra

    (@velitra)


    Hey!

    I use notification plugin and it has been working well. Something happened and now [password_url] shortcode dosen´t work anymore. When you press password link it says that it´s broken. In same notification i have [email_user_login] shortcode and that works just fine. Could someone help me with this issue?

    Thanks
    Veli-Matti

Viewing 15 replies - 1 through 15 (of 31 total)
  • aggk

    (@aggk)

    Hi,

    I have the same issue.
    [password_url] in “new account” mail stopped working

    Strangely, the [password_reset_link] still works and after clicking that the link. …then the [password_url] -link will also work again

    Thanks!

    Plugin Author bnfw

    (@voltronik)

    Hi @velitra and @aggk,
    Thanks for bearing with me whilst I was on holiday over Christmas and New Year.

    Can you see any differences in the URL for both the non-working shortcode and the working one? Trying to work out if there’s some kind of incorrect format or escaping somewhere.

    I have not noticed any difference between the URL:s
    But it looks like it´s related to a WordPress update.
    I just confirmed that it works normal for me when I´m on WordPress 5.2.4
    but the issue occurs as soon as I upgrade to 5.3.2 (not updating anything else)
    and if I deactivate BNFWP the default WordPress messages/links works

    Thanks!

    Plugin Author bnfw

    (@voltronik)

    Hi @aggk,
    Thanks.

    Is BNFW up-to-date as well?
    Regardless, I’ll investigate and see if I can find out what’s going on.

    Yes, both before and after WordPress update I was on BNFW 1.7.5

    Thanks!

    Hi,

    Did you get a chance to look into this?
    (I was hoping I could update before the weekend? )

    Thanks!

    Plugin Author bnfw

    (@voltronik)

    Hi @aggk,
    Not yet. I have a number of updates pending so am planning to push them all out in one go this month.

    Plugin Author bnfw

    (@voltronik)

    Hi @aggk and @velitra,
    Can I ask what notifications you’re trying to use the [password_url] shortcode in?

    Hi,

    For me it´s “New User Registration – For User”

    I use New User Registration – For User. The problem solved with me after login with ajax updated.

    Plugin Author bnfw

    (@voltronik)

    Ok, thanks everyone. Will update when I have more.

    Plugin Author bnfw

    (@voltronik)

    Hi @velitra and @aggk,
    I’ve been un able to reproduce this.

    How are the users registering on your site? Is it via a plugin or the standard Register link on the /login page or is the Admin creating the accounts?

    Hi, I’m using the below in a notification. [user_login] field is fine but the password [password_url] field comes up blank, no link nothing. Any idea on how to resolve this please?

    Hi there.

    You have been assigned a course via ABC Study.

    Username: [user_login]
    To set your password, visit the following address: [password_url]

    Thanks

    Pitz

    • This reply was modified 4 months, 1 week ago by pitz37.

    Users (Author role) are registered from Admin account.

    I just tried again to create an account after disable all plugins except BNFW (+SendGrid which I need for email delivery) and switched to latest default WordPress theme (behind password at staging, WP Engine hosting).
    [password_url] -link leads to the WordPress login page that says the link is not working.
    If I disable BNFWP and create an account the default login link that is sent out works normal.
    I do believe this is related to something between WordPress 5.2.4 and 5.3.2 (like I mention above)

    Thanks!

    Plugin Author bnfw

    (@voltronik)

    Thanks for the extra info @aggk.
    I’ve having difficulty replicating it, even on WordPress 5.3.2.

    Can you post an example of what a working link should look like vs the one that you’re seeing in your emails?

Viewing 15 replies - 1 through 15 (of 31 total)
  • You must be logged in to reply to this topic.