Support » Fixing WordPress » Password Reset Not Working

  • Not sure of the version — the password reset sends an email that provides a reset password link which does not work; error message reads: Sorry, that key does not appear to be valid.

Viewing 15 replies - 1 through 15 (of 28 total)
  • esmi

    (@esmi)

    Forum Moderator

    I have two websites currently running the latest version of WordPress, 3.3 and am having trouble with the password reset feature. I was running an earlier version but upgraded because of password retrieval issues.

    I know my password and am able to log in without problems. All of my users see the error message, “Sorry, that link does not appear to be valid”, while going through the password reset process. I decided to give it a try.

    I clicked on the “Lost Your Password” link and I typed in my username. I clicked on the “Get New Password” button. I checked my e-mail and found the reset password e-mail. I clicked on the link provided in the e-mail at which point I was taken to the website and I was presented with the above mentioned error message.

    I took the advice of my website hosting company and I installed the latest version of WordPress but am still experiencing the same issue. This is not just on one website. It is happening on two sites I run. A couple of my friends are experiencing the same issues on their WordPress websites. They are using a completely different hosting company than the one I use. I figured I would imagine that just to rule out a hosting problem.

    I am afraid to lose all my work by editing anything as far as coding goes. I know nothing about editing databases and I really don’t want to mess something up. HELP!

    Moderator kmessinger

    (@kmessinger)

    What is the url the email gives you? What is your site url?

    Thank you for the speedy reply. Here is the URL of the websites: http://jamesakoury.com/ This is the link that I received: http://jamesakoury.com/wp-login.php?action=rp&key=rmzvO9xqlPglUd0WJ2AY&login=jtk2112%3E

    The password reset form allows you to use your e-mail address or your user name & neither of them work! Not sure where to go from here.

    Moderator kmessinger

    (@kmessinger)

    Time to do some basic debug to rule out plugins or themes.

    – deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems. Also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old

    – switching to the Twenty Eleven theme to rule out any theme-specific problems. If you can’t log in to change themes, you can remove the theme folders via FTP so the only one is twentyeleven. That will force your site to use it.

    – manually upgrading. When all else fails, download a fresh copy of the latest.zip file of 3.3 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first!

    I tried everything you said, starting by deactivating all the plug-ins. I cleaned out my browser cache then went through the password recovery process. Same story! The link does not appear to be valid. What are, mu plug-ins?

    I tried several different themes including the 20 11 and received the same error message. I went on to the next step.

    I downloaded a new copy, that being 3.3 and then I read the manual updating directions. The password reset feature is still not functioning.

    Any other ideas? I appreciate everything you have suggested so far.

    Moderator kmessinger

    (@kmessinger)

    Is this your user name, jtk2112%3E? The user name follows login=
    BTW, if it is, you need to change it.

    Go here to make sure you have the latest java. You might also go to your hosted site and do a db repair (backup the db first) which is usually a one click affair.

    No. It is jtk2112

    Then you’re likely putting in an extra character when you enter your id.

    That’s weird. I only type “jtk2112”, minus the quotes, of course.

    Moderator kmessinger

    (@kmessinger)

    The link works without the last characters, %3E

    Why are these extra characters generated?

    Moderator kmessinger

    (@kmessinger)

    The link is sent with a leading < and an ending > enclosing the url. %3E = >. Check the original email. Neither < or > should be included in the link itself.

    The following is what appears in the email body.

    Username: jtk2112

    If this was a mistake, just ignore this email and nothing will happen.

    To reset your password, visit the following address:

    <http://jamesakoury.com/wp-login.php?action=rp&key=rmzvO9xqlPglUd0WJ2AY&login=jtk2112&gt;;

    Below here is the actual URL; (right clicked / copy link location). –Note the extra characters–

    http://jamesakoury.com/wp-login.php?action=rp&key=rmzvO9xqlPglUd0WJ2AY&login=jtk2112%3E

    Moderator kmessinger

    (@kmessinger)

    Is this marked as a link in the email?
    http://jamesakoury.com/wp-login.php?action=rp&key=rmzvO9xqlPglUd0WJ2AY&login=jtk2112>

    Is ; in the email also as in your reply?

    Where is what you call the “actual” URL shown in the email?

    It should read like this . . .
    To reset your password, visit the following address:
    <http://jamesakoury.com/wp-login.php?action=rp&key=rmzvO9xqlPglUd0WJ2AY&login=jtk2112>

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘Password Reset Not Working’ is closed to new replies.