WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] password reset not working

[Resolved] password reset not working

  • I can’t get into Admin with existing password. I reset password using myphpAdmin, but reset password is not working. (tried reset several times)

    Part of problem is that I upgraded to 2.7.1 but had problem with redirect loop, so reloaded 2.0

    Any help appreciated

Viewing 14 replies - 1 through 14 (of 14 total)
  • If you reloaded 2.0 then hopefully you restored your backup of the 2.0 database…

    Yes, I did restore backup of db

    If you use phpMyAdmin then you should be able to reset the password. Make sure you use the MD5 function when changing the user_pass field to a known value. Also when in phpMyAdmin verify that the user_login field is what you are using for User Name when logging in.

    Yes, I have user-login set to Admin. And am using MD5 for password. But problem persists.

    I have restored pevious db, and previous wordpress files. But something must have changed to create this problem…

    Admin is different than admin

    Have you tried using the Lost your password? link below your wp-admin login page. That worked for me when I upgraded.

    Brian

    Sorry, I meant admin – I am using same case

    Brian – I tried that route originally but encountered different problem – my username and email were not being recognized – despite triple checking I was using the correct ones. So then I tried the phpmyadmin route.

    Are you sure you are ‘looking’ at the correct database.

    Go to phpmyadmin, in the wordpress database push wp-users, browse user_email. That will show you what email is listed for the database.

    Brian

    Michael – I only have one db for wordpress, and I’m sure it is the correct one, because it is the one I that got upgraded when I went to 2.7.1

    Brian – Yes, I had checked the user_mail and it showed I was using correct one

    On examining files, I’ve found following code inserted at top of index.php :
    <?php if(md5($_COOKIE[‘480bfbcdcde9d172’])==”e42328ab54ae9b6d47f0d2bdd04d153a”){ exit; } ?>
    I don’t recall it ever being there before. Is it a hack?
    Tho don’t see why it should create password problem

    I ran into a few problems when I tried to upgrade to the new wordpress, and I backed up my databases and then uninstalled wordpress. Making sure that all files were deleted that had anything to do with wordpress. Then I reinstalled it and imported my backed up databases and everything worked after that.

    Don’t know if that will help you, but it did help me and everything worked fine after that.

    Brian

    OK. Solved. (Never underestimate the value of taking a shower…)

    My browser was caching the admin login page from 2.7.1 – clearing the cache did it.

    Thanks for all offers of suggestions.

    Peter

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] password reset not working’ is closed to new replies.
Skip to toolbar