Support » Plugin: WooCommerce » Password reset error

  • Resolved S Saxena

    (@witage)


    Hello,

    I am facing the problem that password reset is not working. The user gets the email with the link to reset password. But when he clicks the link, it takes him back to the login page with an error message that “This key is invalid or has been used. Please try to reset the password again”
    Can somebody help me with this?
    Following is the link for screen shot.
    https://1drv.ms/u/s!AlQyXA8w7_I1hCvqmE0p-VpzbZhJ

    Regards
    Saxena

Viewing 12 replies - 1 through 12 (of 12 total)
  • Ensure the my-account pages have been excluded from caching in your cache plugin’s settings. Every user has unique my-account pages.

    Hi Lorro,

    I am using wp-rocket and have already selected “never cache this page” for my-account page.
    In WP-rocket settings also I have given the path of my-account page for never caching.

    But I am still facing the same problem.

    Regards
    Saxena

    I was able to visit /my-account/lost-password, and the markup reports that the page is optimised by AssetCleanup Page Speed Booster. I’m not familiar with that but it sounds like some sort of caching plugin. Can it be reset or temporarily deactivated for testing.

    I deactivated AssetCleanup Page Speed Booster plugin and tried again. But the result is still the same. It takes me back to the login page with the same error that “This key is invalid or have already been used.”
    The plugin is still deactivated so that you can also check.

    Hi Lorro,

    I tried by deactivating all the plugins.
    But result is still the same. It takes me back to the login page with the same error that “This key is invalid or have already been used.”

    Regards
    Saxena

    I still think something is caching something.

    I’m seeing something in your page called secureserver.net. I don’t know what that is but its not usual and could be a caching service. You may know it as a CDN or Content Delivery Network. Basically your pages are being cached at servers around the world and the system will serve up pages from whichever server is nearest to the user and so the site loads quicker. However, My-Account pages need to be excluded from that service. Does your host have caching enabled? Do you have any control over CDN within your hosting account, cpanel or similar? If you are not sure, put in a call to your host’s support service.

    I have created an account on your site but I was unable to request a password reset as the reCapture kept spinning indefinitely. On looking at the console, there are 6+ JavaScript errors in the page. Its possible that one JavaScript error is preventing other things from working properly. It would be tricky to fix all those errors via the forum.

    It looks like your theme is v2.1.34 Business Elite from wordpress.org. But when I downloaded it, I received only v1.1.34, so that’s confused me. Did you get your theme from:
    https://srd.wordpress.org/themes/business-elite/

    If not, where from?

    When you did the deactivate all plugins except WooCommerce test, did you also switch to the default theme say Storefront at the same time and test, to be able to rule out a theme issue?

    It looks like secureserver.net could be the GoDaddy Website Accelerator – so a cache service then.

    See:
    https://uk.godaddy.com/help/clearing-the-server-cache-using-website-accelerator-8057

    You need to prevent it from caching the My-Account pages. I don’t have GoDaddy so I don’t know how to do that. You may need to ask GoDaddy support.

    Hi Lorro,
    I checked up. There is no Website Accelerator.
    I bought the theme directly from Web-dorado and I keep on getting updates.
    I have a request. If I temporarily give you my wordpress admin credentials, will you be able to help me on this issue?
    I will be highly obliged.
    Also please check this link where Godaddy says they do not offer website accelerator anymore.
    https://uk.godaddy.com/help/what-is-website-accelerator-8054
    Regards
    Saxena

    Unfortunately, forum guidelines advise against posting credentials or off-forum resolution.

    The link tells us that Godaddy no longer offers Website Accelerator to customers who had not previously enabled it, but I’ve gone off that idea. On further looking I think secureserver.net is monitoring something on your site, rather than caching it.

    The reset password email worked this evening, and I got the email. On examining the reset link in the email, its:
    …/my-account-page/lost-password/?key%5Berro=
    rs%5D%5Bempty_captcha%5D%5B0%5D=3DstrongERROR/strong:%20Please%20confirm%20=
    you%20are%20not%20a%20robot&&id=3D168

    So some captcha problem. I had made a point of clicking the captcha. So please try deactivating your captcha plugin. If it works now, reexamine your captcha plugin settings.

    If you still have a problem, please advise which captcha plugin you are using.

    I am really thankful to you Lorro. You have solved my problem. It was really captcha problem. The recaptcha I was using was not supporting Woocommerce. I changed the captcha and reset password started working.

    I have few more problems and will be highly obliged if you can help me out.

    1. When I use any other registration form, I get a notification mail every time a new
    user registers. But when I use Woocommerce registration form, I do not get any
    notification mail for new user registration.
    2. Woocommerce registration form does not have “Name” column. How can I add “Name”
    column to Woocommerce registration form.
    3. Is there any way to introduce “Activation” in Woocommerce registration form?
    Whenever a new user registers, instead of getting a “Your account has been created”
    mail, the user gets a mail to activate the account and only after successful
    activation, his account will be activated and he gets account created mail.

    Regards
    Saxena

    1. WooCommerce doesn’t do this out-of-the-box. There is some code here that might do it:
    https://docs.woocommerce.com/document/notify-admin-new-account-created/

    or here’s a plugin you can try:
    https://wordpress.org/plugins/manage-notification-emails/

    There’s likely to be other plugins around for this job.

    2. You’ll need to look for a suitable plugin. I’m sorry, I don’t know of one.

    3. Sort of, if you go to:
    Dashboard > WooCommerce > Settings > Accounts & Privacy
    ensure “When creating an account, automatically generate an account password” is checked, then the system will send the prospective new user an email with the password. I think the user is left logged-in first time round, but the user is sent an email with their password, so at least you can be sure the email is valid for subsequent logins.

    Again, there may be plugins out there to do a better job for you.

    If you can’t find something at wordpress.org/plugins, have a look at woocommerce.com and codecanyon.net.

    Plugin Support Fernando

    (@fhaps)

    Automattic Happiness Engineer

    We haven’t heard back from you in a while, and the original issue this thread was opened for has been solved, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Password reset error’ is closed to new replies.