Support » Localhost Installs » password rejected when migrating files to local host

  • Resolved donalmccaffrey

    (@donalmccaffrey)


    Hi
    I have been trying for days to upload my old site to a local host – just so that I can refer to it when developing a new site. I have used duplicator to extract the files and the process using the installer.php file for transferring it over to my WAMP localhost goes perfectly until the final step 4 of 4 when I am asked to login to save permalinks and so on. My password for logging on to the former site dashboard is rejected – I have tried all the other options (my wordpress.com/wordpress.org passwords) all rejected despite the fact they are still operational. I also get the message that my email address is not recognized when I try to reset the password. I have tried everything so any thoughts or suggestions would be very much be appreciated.

Viewing 11 replies - 1 through 11 (of 11 total)
  • There must be something here that I am missing as I have just migrated the site to the local host using all in one Wp migration plug-in which worked well but now when I try to login to the Wp-admin dashboard I am having the same problem with all passwords being rejected. Thanks

    @donalmccaffrey

    The easiest way to remedy your situation is to change your now local admin user via the database using phpMyAdmin.

    – fire up phpMyAdmin from WAMP
    – expand the users table and edit the admin user name (if you want) and enter a new password as normal text
    – the key for this to work is the make sure you select MD5 from the user_pass varchar(255) drop down and then click Go

    That will get you in with the credentials you entered ๐Ÿ™‚

    Cheers!
    Lyle

    Thanks for the help Lyle
    When you say, expand the users table, the only thing I see on My WAMP phpMyAdmin is the ‘Users Account’ tab which (using edit privileges tab) allows me to edit password of existing account or add a new user account. I don’t think this is what you are referring to but I don’t see the users table you mention. Sorry for the hassle but if you maybe pinpoint where it should be. Also the MD5 from the user_pass varchar(255) you mention – is that a separate file or part of the same users table.
    Many thanks

    @donalmccaffrey

    Nope, it is the db for your site ๐Ÿ™‚ Open phpMyAdmin and you will see a listing of the dbs in your WAMP install in the left sidebar. Expand the one for the site in question. Once you do that, you will see a listing of all the tables in that db. Click on the wp_users table. Go from there ๐Ÿ™‚

    • This reply was modified 4 months, 2 weeks ago by  SniffleValve. Reason: typo
    • This reply was modified 4 months, 2 weeks ago by  SniffleValve.

    Lyle
    I think I have found the user table (one for each site per database), which shows – still not sure where the ‘user_pass varchar’ is? I see you have just sent a message, will send this on

    That’s it Lyle,,, don’t see any indication of the โ€˜user_pass varcharโ€™ you refer to?

    I think I have it,,,, thanks a million,,,I would never have worked this one out. I’ll come back in a while to mark as resolved.

    It’s all working great – thanks again

    Lyle
    Related to the above can I just check with you how I can change the username in the wp – users table. Do I also select MD5 from the user_login varchar(60) drop down – the same as the user_pass varchar(255) or do I choose a different option. I tried this but it didn’t seem to work. Thanks for your help again

    @donalmccaffrey

    The username is just a text field and you don’t select the MD5 for that; just edit the name, no spaces, and click Go ๐Ÿ™‚

    Thanks very much

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.