Support » Fixing WordPress » Password protection breaks image uploader

  • I spent the past two hours going nuts over all the fixes for the image uploader. I have several WP blogs in the same server and only my new blog was having this issue.

    Buried deep inside some thread, someone commented that password-protecting the admin area was causing problems.

    I had totally forgotten that I had password protected my whole blog while I was configuring the theme, writing the first few posts, etc!

    Sure enough, removing the password protection makes the image uploader work again. I hope this helps someone…

Viewing 6 replies - 1 through 6 (of 6 total)
  • This doesn’t help me, as I have a private members only blog, and I can not take off the password protection.. but I need to use the flash uploader.. I posted about this issue on another thread that has been marked resolved ( ) yet I do not believe this issue is resolved at all.

    in another thread it was suggested to add a 401 error handling to htaccess from ( ) – but I do not have a wordpress htaccess in my /blog folder (I have not setup permalinks yet) – so I tried adding the 401 erro handling into the htaccess at root – yet it still hangs – no changes, it just does not work..

    any ideas anyone?

    my history of this issue – reposted from my comment on other thread:

    when I click on picture upload, then select files, I can select pictures to upload, but after a picture is selected, both firefox and Internet Explorer immediately ask for a username and password. So I have attempted to enter that information, and then also attempted to add that info and select the checkbox for IE and firefox to remember that info, yet it still seems to hang and fail no matter what.

    I did manage to get an error code from internet explorer once:

    Line: 1
    Char: 128
    Error: ‘SWFUpload_0’ is undefined
    Code: 0


    This problem only occurs with the “flash uploader” – the browser uploader option does not cause this problem.. but we need to use the flash uploader, as it is the only way to select and upload multiple pictures with wordpress, and we have hundreds of photos to upload this way.

    Your help is greatly appreciated!

    bump – anyone found a fix for this?

    It’s recommended to password protect the wp-admin folder, however I can’t add any images with this bug

    dsided – same thing is happening to me now. I run WPMU 2.8.1 and it just started doing what djsteve quoted in his post.
    Very annoying because like he says, I really need to upload multiple images!


    Having the same problem… I need the password directory protection and would like to use flash uploader. Same problems as described and desperate for a fix! I cannot temporarily remove the password protection for the directory in order to simply use the flash uploader as I have multiple usernames and passwords, not just one or 2.

    Has anyone found a fix for it yet?



    I too am having the same problem. Upon securing the wp-admin folder with htaccess/htpasswd, the flash uploader stops working. After a thorough search I found the following information about flash:

    “It turns out that Flash, in all browsers besides IE, does not retain a basic authentication session when posting the files for upload. This is a well known problem among flash upload developers because it breaks every application, but there really isnt a great fix.”

    As it turns out, the flash uploader problem is non-existent in IE. I have tried several other browsers (firefox, safari, chrome) and in all of them the flash uploader is broken. IE currently is the only browser in which the flash uploader works properly with htaccess/htpasswd authentication. When you go to upload, it asks you for your htaccess user/pass again and then continues to upload successfully.

    For me, this has gone from a critical problem, to just an annoyance since I don’t normally use IE for anything except development previewing.



    Would really like to see the WordPress geniuses figure out a way around this. 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Password protection breaks image uploader’ is closed to new replies.