Support » Fixing WordPress » Password Protected Post Help

  • kcbluegal


    Hi there! I’m trying to set an individual post as password protected.

    I can successfully write and password-protect my post. The problem is when I go to read the post.

    1) I can enter in the correct password, but the page loops and again shows me the “enter password” request. If I can then only view the post in question IF I select the title (link) of the post from the main page.

    2) I cannot view the post at all if I’m on the specific page even after supplying the correct password. It does the same thing: refreshing to show me a “enter password” box. If the correct password was supplied on this page previously, then you can only view the post by going back to the main blog page.

    To better illustrate, I have set up a Test Post.

    Visit the Blog as illustrated in:

    Visit the Blog as illustrated in:

    The password is “penguin” without the quotes. This is a generic password specific only to this test post, so no privacy on my part will be lost by posting that password.

    This password protection has worked previously, so I know it’s a glitch somewhere, but where?

    Thanks if you can help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I’m having this same problem of being loop back to enter the password although it’s the right password.

    is there anything wrong?

    Can anyone help me please?


    I’ve had this problem forever. I can edit the password protected page if i’m logged into my admin account, but can’t actually view the page itself on the web site. I’m still running WP 1.5.x. And .. the behavior is the same in Opera 8.5, FF, and IE7.

    Joni Mueller

    I have same issue… it worked when I used wordpress 2.01, but I just upgraded to 2.05. I also tried 2.06 beta.

    I have managed to determine that it’s a database issue, a new database can post a password post just fine, my old db can’t. I looked through the database and can’t find anything wrong with it.




    I was having a similar problem consistently until I turned off Search and Destroy’s teatimer (beta-version). Check that you are not blocking coookies in any program that might block cookies. (Before I started blogging I routinely blocked any cookie that came near my machine.)
    (in IE7 tools privacy sites check blocked lists)

    Still issues, though. There is a timing issue with the cookies.
    I am using 2 different passwords for 2 different pages (same code as post passwords, I believe).
    I can enter password for 1st page & get in.
    I enter password for second page and get the loop.
    I wait a couple minutes and can get in again to my choice of pages.

    I get the first password stored to 2 different cookies one under:
    Documents and Settings/ MyUserName/Cookies
    and one under

    I did modify wp-pass.php from 10 days to 1 minute

    // 1 min
    setcookie('wp-postpass_' . COOKIEHASH, $_POST['post_password'], time() + 60, COOKIEPATH);

    I’m running:
    WordPResss 2.2
    IE 7
    Adsense-Deluxe 0.8 widget 1.0

    PJW WordPress Version Check
    StatCounter for WordPress 1.01
    WOrdpress Database Backup 1.8
    wp-cache 2.0.19 (Doesn’t work whether this is activated or not.)

    if you want to try 2 password operation on your machine I’m at
    Everyday Disasters {dot} com
    Cub Scouts
    PWD Set A – no password
    PWD Set B – password = PWDB (not the normal password)
    PWD Set C – password = PWDC (ditto)

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Password Protected Post Help’ is closed to new replies.