Support » Plugin: All In One WP Security & Firewall » Password Protected Pages not working

  • Resolved Chris Vacano

    (@digitalzen)



    Hello,

    One of my clients just discovered that their password protected pages are not working on her site. The page loads with the password challenge, but when the correct password is entered, a ‘not found’ page is returned.

    When I disable AIOWPS, it works fine. I’ve tried both methods of brute force prevention (renamed login page and cookie-based) and in neither case do the password protected pages work.

    I’m not sure when they stopped working. I presume it was recently, since those pages get a fair bit of use, but I don’t monitor it, so I can’t be certain. My client says they were working as recently as last week.

    If it helps, the site uses Femme 2.1 by CSSigniter as its theme.

    Any help greatly appreciated!

    Thanks,
    Chris

    https://wordpress.org/plugins/all-in-one-wp-security-and-firewall/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi Chris, have you enabled the following option My Site Has Posts Or Pages Which Are Password Protected found under Cookie Based Brute Force Prevention.

    Regards

    Hi mbrsolution,

    I should have mentioned that in my initial post. Yes, I did select that option. In fact, that’s what prompted me to try using Cookie Based rather than Renamed Login. Still no luck.

    Chris

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi Chris, can you disable all your other plugins except this one and test to see if it works?

    If the above does not work can you test one of WordPress default theme and see if that works?

    Plugin Author wpsolutions

    (@wpsolutions)

    @chris Vacano,
    Are the password protected pages using the native wordpress password protection feature?

    Does the problem still occur if you have none of the “brute force” features active?

    Furthermore, have you tried disabling ALL features of the AIOWPS plugin and then re-enabling one by one until you find which one is causing your problem?

    It’s a live site, so testing a default theme is going to be tricky. But I can certainly try the other suggestions. I’ll start by disabling all features in AIOWPS and then re-enabling.

    Thanks for the suggestions. I’ll report back my findings.

    Chris

    Hmmm, funky!

    So I shut off Cookie-Based BFP, thereby leaving all BFP disabled, so I could test. Sure enough, I was able to get into the password protected pages. I turned it back on, but this time, unchecked the AJAX option, which I don’t really need, and ba-boom: everything still works.

    wpsolutions, you may or may not want to take a look into that, but as far as I’m concerned, stuff’s working fine, so I’m going to mark this resolved.

    Absolutely love this plugin, by the way! 🙂

    Chris

    Chris Vacano

    (@digitalzen)

    UPDATED: The problem persisted, but after a little bit of creative fiddling, I found that by turning off IP Whitelisting, the problem went away. wpsolutions, It might be worth a look. 🙂

    Cheers!
    Chris

    Plugin Author wpsolutions

    (@wpsolutions)

    Thanks for the info.
    I did some tests where I had combinations of whitelist and the brute force features active and wasn’t able to reproduce the problem.
    Maybe it was something unique to your setup…..we will keep an eye out if anyone else has this issue.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Password Protected Pages not working’ is closed to new replies.