Support » Fixing WordPress » Password Protected Pages Not Working

  • I have password-protected pages on my WordPress site. However, when I visit the page and enter the password, it simply re-asks for the password — it does not grant the user access.

    I am using the WordPress 2017 theme and have no additional plugins. I cannot find any advice on why this problem occurs and how to fix it. Can anyone help?

    Leon

    The page I need help with: [log in to see the link]

Viewing 15 replies - 76 through 90 (of 96 total)
  • terrie1103

    (@terrie1103)

    Still a problem. Updating Divi made no difference

    a305587

    (@a305587)

    Yeah it broke again for me too, unfortunately I had to move on to a bigger issue.

    I’ll circle back if I get more bandwidth. Here’s a troubleshooting suggestion for you: Try switching themes to TwentyNineteen, make a new post with a password. If the password feature works, you know it was Divi that was breaking the password function. The good news of that would be you could reach out to Divi tech support. If the password feature still doesn’t work, you know it’s not the theme and something wrong with the core wordpress function.

    mchenryscott

    (@mchenryscott)

    SOLVED FOR ME!
    I selected “Never cache this page” on the page settings, I also added page url to my “never cache this page” list for my security (Sucuri) and now it finally works.

    Good Luck!!!

    hlnrnld

    (@hlnrnld)

    I have a different issue with a password protected page. The field or box doesn’t appear for the user to paste the password. It only shows an ‘Enter’ button, when clicked returns the user back to the same page without the password field. See link: https://jazzaar.com/association-membership/rec-workhops/

    Strangely this problem only persists on that one password protected page. I have other such pages that work just fine. See link to compare: https://jazzaar.com/downloads-auditions-2019/

    What could be the problem with the page that doesn’t show the password field?

    Thanks in advance to anyone with a solution.

    I had the same problem. I just noticed it works fine in incognito mode. Must have to do with cache.

    UPDATE 5MINS LATER: I cleared cache and the issue was resolved.

    • This reply was modified 10 months, 1 week ago by vigwe.
    abaylis

    (@abaylis)

    The password assigned to a protected page is not working. I am redirected to the Submit Password prompt. I have tried it in Chrome and Explorer … Any suggestions?

    larryfields.007

    (@larryfields007)

    I’ve noticed sometimes you have to enter the password twice to get it to work. This seems to be random and doesn’t always happen.

    thoraldus

    (@thoraldus)

    Disabling WP Cerber custom login fixed it for me.

    Hi all, I’ve tried everything in this thread, but the problem persists. Does anyone have an update?

    I just recently ran into this issue with a friend’s website that I am supporting. She wanted to move all of her previously public website pages to password protected. It worked fine until yesterday. Using Chrome as the browser, and with incognito windows as well, just kept showing the page to enter the password.

    I woke up this morning thinking that I just needed to clear history on my laptop, which I did. Now all of the password protected pages are working just fine.

    It was an easy fix on my end, so I just wanted to share, with the intent that it helps someone else as well.

    I give the password to my password protected page as an incentive for users to join my mailing list, but I’ve received several emails saying the password isn’t working.

    I haven’t been able to recreate the problem myself, but after researching, the best answer I could come up with is that it’s a caching issue.

    I was able to “exclude” or white list the page in my Cache plugin. I guess I’ll have to wait & see if I get another email before I know if it’s truly working..

    I was having the same issue. The solution for me was to go into my Cache Manager in CPANEL and add the password protected page as a Bypass URL under the Options tab.

    rkgarrison

    (@rkgarrison)

    The solution for us was to create a new blank “dummy” page (kept out of menus, etc. so users would be unlikely to accidentally navigate to it). I link to it in the sidebar of the problem page with a “Trouble logging in?” heading–the sidebar shows always, even before you log in. I password-protected the dummy page with the same password as the problem page; after you log in to the dummy page, I have only language and a link prompting the user to return to the problem page. I also added instructions to clear the cache and try again if the dummy link does not work.

    This has been the solution for us so far. I imagine there is something about the problem page (maybe a plugin) that I have not been able to fix because I personally cannot reproduce and therefore test it.

    For me, the best way to fix this was to pull the password protected page out of the LiteSpeed cache. It’s easyto do if you are logged in. You simply find the LSSC icon on the top admin bar and from the dropdown choose “Mark Page As > Non-Cachable”.

    I don’t love this solution as it slows the page down however since search engines can’t get to it it won’t hurt your rankings – just might annoy your visitors….

    RESOLVED

    Hi all,

    i found the problem in my site.
    In my functions password form is customized but wordpress changed action of form.
    I don’t know when….

    FROM
    action=”‘ . get_option(‘siteurl’) . ‘/wp-pass.php”
    TO
    action=”‘ . get_option(‘siteurl’) . ‘/wp-login.php?action=postpass”

Viewing 15 replies - 76 through 90 (of 96 total)
  • You must be logged in to reply to this topic.