Support » Fixing WordPress » Password Protected Pages Not Working

  • I have password-protected pages on my WordPress site. However, when I visit the page and enter the password, it simply re-asks for the password — it does not grant the user access.

    I am using the WordPress 2017 theme and have no additional plugins. I cannot find any advice on why this problem occurs and how to fix it. Can anyone help?

    Leon

    The page I need help with: [log in to see the link]

Viewing 15 replies - 61 through 75 (of 85 total)
  • zomborro

    (@zomborro)

    I faced exactly the same issue. In the end the plugin ‘WP Super Cache’ was to blame.

    The solution was to REMOVE the WP Super Cache plugin and Install it again. All problems solved.

    I’m still struggling with this, although my issue is a little different. It seems to work in Chrome but does not work in Safari. For some users, they can enter the pw then see the content, as it is supposed to work. For other users, they get a white page. some users get right in, without a password. Caches have been cleared. I believe the page recognizes IP addresses, which makes it almost impossible to troubleshoot because once someone is in, they’re in.Clearing cache doesn’t do anything. Clearing the site cache also does nothing.

    I do not have the super-cache plugin

    Not one thing here has helped and the problem is so inconsistent that I give up. I have cleared caches, I have gotten rid of/disabled plugins, I have tried some of the coding, I have tried every single thing here on this thread. The problem HAS to be wordpress. Often it looks solved, but comes back. I also think that the pw protected pages do not cache but rather recognize IP, which makes it incredibly difficult to troubleshoot. I give up!

    @terrie1103 Password protected pages do not recognize IP (that would be a security flaw as IP can be spoofed). They set a browser session cookie. When a browser is completely closed, the cookie expires and they will require a password once again.

    The issue could be your hosting setup. Do you have another testing environment on a totally different server? I would ask your host for help, try a different hosting platform, or hire a developer. So far, this “bug” has never proven to be due to WordPress core.

    I’m not saying WP is infallible. I just really think something else is at play.

    @terrie1103 I’d be happy to lend a hand troubleshooting as time permits. I’m a developer in CT.
    http://www.vandertech.com
    james@vandertech.com

    Thanks so much. I will check in with the hosting company. I do have another site that it worked on..so maybe that is the key!

    I’m having the same problem. Running Divi theme. Password protected page does not accept password, just re-loads password field. None of the suggested fixes in this thread have worked for me.

    • This reply was modified 4 months, 4 weeks ago by a305587.

    Yep, I am also running Divi

    It miraculously fixed for me when I updated Divi.

    Side note: It’s an endless irritation with me about Divi that random things will break every time they release an update. It’s almost how I know there IS an update available. Something stops working.

    So terrie1103, go to your dashboard –> updates and see if Divi has sneaked an update package for you to install. I had one hidden in there and there wasn’t a warning flag for me to draw my attention to it until I clicked into the Updates section. Divi 3.26.3 was available to update but it hadn’t otherwise notified me.

    Good luck!

    • This reply was modified 4 months, 4 weeks ago by a305587.

    thanks very much. I am pretty sure I have it updated, but will definitely check! OF course, Divi denies it’s them. Yet- I have built the exact same page in another theme with no issue. The page also worked before I flipped to Divi.

    If you see the problem again, perhaps we could compare plugins to see if we are both using something that could be causing a conflict. I did try shutting them all off at one point, but, I supposed that’s not the same as a deletion.

    I reached out to Divi tech support and they denied it was them with me as well. Then I performed the update and voila! It worked again.

    I’m sorry, but to me that’s being caught red-handed. Might as well had their hands in the cookie jar. And it’s not the first time I’ve run into this problem where something suddenly stopped working because Divi released an update. Just wish they’d own up to it.

    Still working for me as of this morning, but if that changes I’ll circle back and be happy to test the plugin experiment you described. Good luck to you.

    If you like Divi then try Astra https://wpastra.com/

    I’m having a ton of success building with it and Elementor. It’s super lean.

    ANY update on this? I just started one of these 2 months ago. Password was working fine for people and now it has stopped working.

    I changed the password and updated the page but it’s still not working.

    @daragdaragrenniecom Did you go through all the troubleshooting steps I wrote in this reply https://wordpress.org/support/topic/password-protected-pages-not-working-5/page/4/#post-11344766 ?

    So far, no one has been able to trace this to a WP core bug. It’s always some interaction between the server setup, caching, cloudflare CDN, theme and/or another plugin.

    I recommend trying all steps in the troubleshooting guide. You may also want to activate a different theme and retest as users of Divi seem to have issues with certain versions.

Viewing 15 replies - 61 through 75 (of 85 total)
  • You must be logged in to reply to this topic.