Support » Fixing WordPress » Password Protected Pages Not Working

  • I have password-protected pages on my WordPress site. However, when I visit the page and enter the password, it simply re-asks for the password — it does not grant the user access.

    I am using the WordPress 2017 theme and have no additional plugins. I cannot find any advice on why this problem occurs and how to fix it. Can anyone help?

    Leon

    The page I need help with: [log in to see the link]

Viewing 15 replies - 16 through 30 (of 86 total)
  • Adjusting cache settings isn’t practical since we are running this for a club with many elder members. We are running no special plugins. And while it seems to be browser related, I have other sites that work fine. And this one worked fine for years, then went bonkers. Does anyone know of WordPress experts you can pay to troubleshoot code? I am a designer, not a coder.

    I’m having this problem too.

    I believe it is a caching problem as mentioned by @shaunacallaghan but I do not know how to resolve it.

    Does any one know how to fix this problem?

    As I wrote on one of the other forum pages earlier today…

    The same thing was also happening with the plugin: WooCommerce Password Protected Categories by Barn2 Media. I was able to solve the issue for this plugin using the information they posted here: https://barn2.co.uk/kb/password-not-working/

    “How to fix the page refresh problem

    Ask your caching provider why pages using the WordPress cookie for password protected posts is not being excluded from the cache.
    Add a rule to the caching plugin settings to exclude the product category pages from the cache.”

    But I have not been able to resolve the issue on password protected pages by excluding them from my caching plugin (which is LiteSpeed Cache by the way).

    I am also having this issue. I have a new post created. I’ve set the following:
    status = “Published”
    visibility = “Password protected”

    When I open the page in a new browser I actually get different behavior in different browsers:
    Firefox: the page reloads with the password form no message or indication of failure
    Safari & Chrome: Blank white page

    WTF?

    I’am having the same issue. Changed Theme, deactivated all caching, still no access. Tried it in FireFox, Chrome, Safari and Opera, all negative.

    Any solutions?

    Me too. Same issue worked well until a few weeks ago, now won’t work for toffee!!

    I am having this issue as well. I have made no plugin or theme changes and it just suddenly stopped working for some people, sometimes.

    I am having this issue as well, has anyone resolved it? Thought I would bypass the WordPress password protection feature and use a plugin, but can’t seem to find one that simply protects one page…

    I have not yet found a fix. I hired someone to figure it out and they have been working on it since I posted my previous comment 3 weeks ago…

    Please share any information if you can, thanks for responding!

    Will do!

    As I posted a couple of months ago, I had this issue too. But… it is solved.

    What I did:

    Re-installed WordPress via Dashboar – Updates
    Changed access rights, all WordPress maps to 755

    Hope this helps you too.

    Having the same issue. I read on another post “the wp-login.php page is part of the login process for these protected pages. If that page has been renamed or hidden or is otherwise not accessible for all users, that will also break the password-protect function for individual pages”.

    I’m curious to know if others that are having this issue have also modified their login urls. If so, anyone have an alternative/fix?

    same probleme ….

    Hi @blniko ! Curious… regarding what you said about wp-login.php, what if a security plugin renamed the login, and then the plugin was de-activated. Could that be the issue? If so, what do you suggest to do to fix it?

    Hi @lidialv . The site I was working on is not on a shared host. The IT guys that manage it first tried changing the url back to the standard wp-login.php, but that did not fix the issue. They stated “it was cloudflare issue not related with any plugin”, but did not give me any further detail. Hope this helps. Sorry I don’t have specifics.

Viewing 15 replies - 16 through 30 (of 86 total)
  • You must be logged in to reply to this topic.