Support » Fixing WordPress » Password Protected Pages Not Working

  • I have password-protected pages on my WordPress site. However, when I visit the page and enter the password, it simply re-asks for the password — it does not grant the user access.

    I am using the WordPress 2017 theme and have no additional plugins. I cannot find any advice on why this problem occurs and how to fix it. Can anyone help?

    Leon

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 85 total)
  • For the avoidance of all doubt:

    1. I am using the 2017 theme. When I changed it, it still did not work.
    2. I disabled all plugins. Still, nothing.
    3. I tried on different browsers and different browsers. Same problem.

    So … I am very confused!

    I think you got the topic all wrong,
    I belie what you meant was how to make a password protected page public.

    Making use of your dashboard go to the affected page and you would probably notice a publish section at the right , before that publish/update button at the top you would notice an area that says visibility ( likely that would state password protected ) press the edit beside it.
    As you should be able to see the password made use to lock the page.
    {– to make it public just select the public button —
    and then update }

    https://postimg.org/image/pz24l3eph/

    wow, made a typo ( belie = believe)

    Hi,

    Sorry, but that is not what I meant. Let me explain again:

    I have created a page with a password. When users go to that page, they see: “This content is password protected. To view it please enter your password below.”

    So far, so good.

    But when they enter the password (and, yes, they have used the correct password), they still get the message: “This content is password protected. To view it please enter your password below.” They cannot access the page’s content.

    I use the default 2017 theme and disabled all plugins. The problem persists.

    Any advice?

    Leon

    Am not fully sure what may be the reason, but i would likely tell you to consider this possibility.
    1) it may possibly be a theme issue – as you can try another theme to see if the page shows when using the pass( changing themes may disrupt the widget positioning as you can arrange them back the way it was but may take time)
    2) am not sure why index.php gets displayed before showing the page url – I suggest you get this fixed as i doubt you want your visitors seeing that and it also being index by google

    I also created a password page on my site and logged out and tried the pass as a visitor and works for me, hopefully someone gives you a better solution and hope you do get it fixed.

    regards,

    Thanks for the ideas.

    I did remove the theme and replaced it with another. The problem remains.

    I have just removed the index.php from the URL with the help of my hosting company. But the problem persists.

    I have no idea how to fix this issue.

    Any ideas on this problem? Anyone?

    Any ideas on who can help me with this problem? It persists.

    Were you able to get this resolved? After several years of no problems, the password suddenly doesn’t work, keeps reloading the password page. I have rebuilt password and page and still doesn’t work. But it is sporadic, works in some browsers and not others, and will sometimes work after several tries. Any help is appreciated.

    I have the same issue. I have created a page with a password. Page displays “This content is password protected. To view it please enter your password below.”
    But when you enter the password, you get the message: “This content is password protected. To view it please enter your password below.”

    I have this issue as well. Exactly as described.

    I post to get notified if anyone post a solution.

    Thank you

    • This reply was modified 1 year, 7 months ago by pedroajenjo.

    I am having this issue as well. Password protected pages suddenly won’t accept password EXCEPT in Safari. Wondering if it could be browser related.

    This is an URGENT problem! I have managed to get the password to work in Explorer only. Not exactly the fix my client is looking for.

    I was able to fix this issue by adjusting our caching settings.

    I to am having this issue and I am not using a Cache plugin

Viewing 15 replies - 1 through 15 (of 85 total)
  • You must be logged in to reply to this topic.