WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Password protected pages not working

[Resolved] Password protected pages not working

  • I am trying to password protect a couple of pages. The password prompt appears on the page but when I try to enter the password it does nothing. I have tried changing passwords etc but nothing works. I have looked at similar posts about this problem and have tried deactivating all my plugins but to no avail. So I am now stumped! I am using 2.9.2 and interestingly password protected pages did work in earlier versions.

    I am now looking for a way around this. I really need to have a password protected page rather than have users log-in.

    Does anyone know another method – this is so frustrating.

    Thanks for any help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Is wordpress saving password for your posts ?

    In wp_posts table, check this field: post_password. There should be the password you have entered for your post. If it is not saved properly, try adding manually in database..

    Also, make sure you upgraded properly ( I mean you didnt miss any file from the new installation)..

    Thanks for this. I looked in wp_posts table and my password is in fact there in row 3 with another test password in row 1. I upgraded via the auto install so maybe something is missing?

    I have now solved the problem. Seems to be WP Cache plugin that was causing the problem, I have now deleted it and the password protected pages work as they should.
    Hoorah!!!!!!

    deactivating the “Exclude Pages from Navigation” plug-in fixed it for me.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Password protected pages not working’ is closed to new replies.