Support » Fixing WordPress » Password protected pages does not work

  • Resolved barthdesigns



    Been using WordPress with Avada for 3 months now. I like it very much, used Weebly before, but I like WP more.

    I have a problem though, which I was unable to solve with Avada and WooCommerce authors. Both of them asked me to move on and turn to WordPress Support, so here I am.

    The problem is: no matter if I turn off Avada and turn off (deactivate) all plugins, it still persists. There is two problems, but I think the root cause must be similar or the same.

    So when I try to use password protection for a page, it does not accept the correct pass, simply reloads page. I tried with 2-3-4 pass variations, it is not the problem. It simple reloads the page after entering correct pass, and once again ask for pass.

    And the second problem is the same: I have installed a free WP LOCKER plugin, which password protects product categories. It should work, but it does the same, refreshes page after enetring password correctly.

    And it is very strange as sometimes it accepts the password.

    Please let me copy the list I did, asked by Avada and Woocommerce to solve the problem. It might be helpful:

    – updated Avada (did the backups)
    – updated all plugins
    did not help

    – deactivated all plugins except WooCommerce
    did help, I managed to sign in using the password

    OK, so one plugin is to be blamed. I thought, let’s turn them on step by ste-
    – I turned on the first 3 plugins (Accordion plugin, Bullet Security plugin and a Cookie plugin)
    – everything was fine, I changed password and managed to sign in again
    – great, then I activated another group of plugins: Custom Page Label, Duplicate Page, Easy Hotjar, FB Pixel and Fusion Builder.
    – than the password did not work

    Oh, how great, I found the plugin, it must be 1 of those 5! So I turned them off one after one.
    And without logic, it did not help. I even turned off the first 3 plugins I’ve activated at first, and the password did not work again.

    Then, I switched to another basic theme. Did not work, so switched back to Avada.

    I have no other idea. Please feel free to sign in and do as you wish as I can not seem to solve and I am out of ideas what can cause so random working/not working.

    The password for that page I’m trying to set uo is “proba”


    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • kjodle


    It’s giving the default behavior for entering a wrong password. Are you sure that “proba” is the correct password? No caps lock on or anything?

    Be sure to try with all your plugins turned off, including WooCommerce. It may be possible that WC is conflicting with some other plugin (even if it’s deactivated).

    Have you check your server error logs for anything weird?



    Thank you so much for your reply!

    I did some other settings and here’s what I found:

    So it turns out that if WP Locker plugin is activated, neither that plugin, nor the regular Page password protection function works.

    If I turn off WP Locker, than Pass protected pages function works fine.

    So it’s something in the plugin that causing trouble. But it is very strange: no matter if I turn off Avada theme, or turn off all the plugins (only WooCommerce left as the WP locker is assocciated with WooCommerce plugin) is still does not accept passwords. Authors have no idea neither.

    Will keep digging, thank you for your help!!



    WP Locker plugin is activated, neither that plugin, nor the regular Page password protection function works

    Sounds like that plugin is not doing what it is supposed to do. Maybe it’s time to ditch it.



    Yep… but unfortunately there is no other free alternative for that purpose, only a $75 plugin from WooCommerce. Too bad 🙁

    Still, I think Wp case solved, thank you!



    Cheers! Sorry there’s not a better resolution for you (yet).

    I’ve got the same issue with password protected pages not accepting the correct password.

    The same thing was also happening with the plugin: WooCommerce Password Protected Categories by Barn2 Media. I was able to solve the issue for this plugin using the information they posted here:

    “How to fix the page refresh problem

    Ask your caching provider why pages using the WordPress cookie for password protected posts is not being excluded from the cache.
    Add a rule to the caching plugin settings to exclude the product category pages from the cache.”

    But I have not been able to resolve the issue on password protected pages by excluding them from my caching plugin (which is LiteSpeed Cache by the way).

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Password protected pages does not work’ is closed to new replies.