WordPress.org

Support

Support » How-To and Troubleshooting » Password Protect Posts NOT working

Password Protect Posts NOT working

  • I have tried password protecting posts with the option installed in WP and it does not work. Is there anyone who knows of a plugin that works for protecting posts? I have tried Category Access and Category Visibility -RH-Rev and really gave them both a good trial. Neither one works. I am using the latest WP and the Tiga Theme. HELP! 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • What about the built-in password protection doesn’t work?

    When testing it, you DO want to log out of your blog first…

    It still doesn’t work. Another wp developer lead me to his page. It didn’t work on his either. I have logged out and entered the password. It doesn’t work. I have even tried opening up IE browser instead of Firefox to see if the issue is there. It didn’t work.

    Everything looks normal until you enter the password. Don’t worry, I checked CAPS and everything. The browser excepts everything but the page does not change. It will not show you the post!

    BTW, this support community is AWESOME! I’m really impressed!

    Can you elaborate a bit on “didn’t work”? Perhaps describe what you expected to happen vs. what you saw?

    Also, I’d be very curious to know what plugins you’re running. If wp-cache is one of them, visit options wp-cache and disable it and try again.

    In my testing, password protecting seems to work just fine for me.
    I created a new post and gave it a password.
    After I published it, I logged out.
    Viewed my blog, saw the post had a password prompt.
    Entered password, saw the post.

    Your right, it did work (I had made a mistake as to which password went on which page)on the other developer’s site. I guess it is a theme issue. The developer has not been on his site in a while. I guess I need to look for another avenue. Any ideas?

    Hi, I’ve WordPress 2.3 installed on my blog. Interestingly I have never been able to access posts after password insertion.

    Scenario: I make a post Pwd protected: save/publish: open the post, enter the password. It takes me again to same enter pwd page and never displays the post.

    What should I do? In your opinion, what should I be checking to rectify it?

    thnx!

    Hi,

    I have the same problem as described above, except I’m trying to password protect a page.

    Here is what I do:
    0. wp-cache disabled
    1. create a page and add password
    2. save and publish
    3. access page with another browser (firefox)
    4. enter correct password multiple times but page is not displayed

    Any hits ?

    I’ve fixed my problem by using this solution:

    http://wordpress.org/support/topic/144787?replies=3
    regards, ari

    Cancel that, that solution accepts whatever password and displays your “protected” page/post content.

    Still looking for a solution to this problem.

    BTW. I’m running 2.5

    regards,
    Ari

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Password Protect Posts NOT working’ is closed to new replies.