Support » How-To and Troubleshooting » Password gone missing after upgrade

Password gone missing after upgrade

  • I jut upgraded to 1.2 and it changed my password. I went and tried to retrieve it but in the email sent it only said:
    Password: b336d2
    without a log-in name.
    and when I try it with my exsisting name it doesnt work.
    I went to mysql admin and changed the b2_users data and put a new password there but that didnt help either, help me!
    what do I do now???????

Viewing 15 replies - 1 through 15 (of 26 total)
  • have you tried “admin” for the username?

    I had this problem, and after deleting and remaking my database with no success, I ended up deleting all the cookies from my website, and then logging in with the new password. Its an odd problem, I’m not sure why it happens, but it seems to be caused by invalid leftover cookies being read by the new installation.

    yeah I’ve tried admin, was the second thing I tried.
    I ended up reinstalling the whole thing 🙁 of course I had a backup of my posts but it still sucks

    This is happening to me too.
    Blank space where user should be in the reminder email …
    Just sits there and won’t let me through to the admin section.

    Sorted mine after much clicking.
    Opened up the wp_users table, deleted my password from there, got a new hashed password from http://bfl.rctek.com/tools/?tool=hasher
    put that into the password field, and now I am back in :)))
    Much joy.
    /me wanders off to make a backup !

    I tried that… no luck.
    No luck clearing cookies from my browser or emptying the cache.
    If someone could tell me how to empty the cookies from my website, I can try that. I’m not quite sure what that means.

    Cookies are in your computer.
    In windows
    C: – docs and setting – username – Cookies folder.

    i deleted these.. no luck. still won’t work for me.

    podz is the man, that shit works.
    in my db, the row was named “b2users” though.
    maybe cause i upgraded from b2.
    anyway, thanks x100.

    I’m having the same problem. OK, maybe it’s because I’m frustrated but I’m going to need more explicit/specific instructions to solve this problem.
    Podz says:
    Opened up the wp_users table, deleted my password from there, got a new hashed password from http://bfl.rctek.com/tools/?tool=hasher
    put that into the password field, and now I am back in :)))
    Ok I don’t understand exactly. Where is the wp_users table? You’re not talking about the users.php file in the admin folder, are you?
    I was excited because the install went w/o any hiccups, looked good, then I went to add a post saying such, and now I can’t get in…
    I really need to be working on my MA thesis, not this. Any help would be appreciated. But like I said, I’m fried. So please no assumptions, please be as explicit as possible with your instructions. Thanx again.

    Your blog host should provide you with phpMyadmin access to your databases for you to do this.
    Open phpMyadmin, and click on the users table in the left menu (it could be wp_users, or yourprefix_users)
    Click “Browse”
    Click on the edit button next to the admin user.
    Delete whatever is in the password field.
    Now go to http://bfl.rctek.com/tools/?tool=hasher
    enter your desired password, and copy the hash that it generates
    Paste the hash in the password field for admin
    Save the info in the database.
    Login to WordPress using “admin” and the password you used to create the hash.
    There. If any details are missing, I will be glad to fill in. 🙂
    Give it a shot.

    2fargon, thanks from me as well. I had the same problem, followed your steps, and all is well.
    Many thanks!

    i just followed these very implicit and EXCELLENT directions, and fixed my friend’s site. THANK YOU.

    For those who are having trouble with the (“lost your password”) password retrieval process, there is a simple bug in the wp-login.php script. It’s easy to fix.
    Go to the “case ‘retrievepassword’:” section.
    Just under the the comment:
    // redefining user_login ensures we return the right case in the email
    $user_login = $user_data[‘user_login’];
    $user_login = $user_data->user_login;
    It looks like a classic “copy-and-paste” coding error.

    Ok, I’ve tried EVERYTHING that’s mentioned here. removing cookies. doing the md5 hash thing. fixing the wp-login page. Nothing lets me back in.
    This is actually the second time this has happened to me. The first time, thankfully it was only a test blog, but I had to completely wipe out my database and start from scratch. Please help! I was hoping I could officially move my blog over from MT to WP this weekend, but this is making me very nervous!

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘Password gone missing after upgrade’ is closed to new replies.