Support » Plugin: Disable and Remove Google Fonts » Passionate Pro theme refuses to cooperate

  • Resolved Simon

    (@sdellenb)


    The Passionate Pro theme has Google Fonts support added over the free version, and those are always loaded from fonts.gstatic.com.

    A workaround is to change all fonts in Passionate Pro’s typography settings to “Default” and then to configure the fonts in Fonts Plugin Pro with “Host Fonts Locally” enabled.

    It works for all fonts I tried, except Roboto, the theme’s original font. That one is still being loaded from fonts.gstatic.com. This is how the test site linked is configured right now.

    I can give you access to the test site or a copy of the theme if required.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Danny Cooper

    (@dannycooper)

    Hi @sdellenb,

    I’ve tested this theme in isolation and the plugin appears to be working to remove Roboto. Are you certain there is no caching in play or another plugin is adding the font?

    Thread Starter Simon

    (@sdellenb)

    Thanks @dannycooper,

    I’ve tried disabling all plugins except “Disable/Remove Google Fonts” and “Mega Menu Plugin for WordPress” (theme uses it) and set the “Site Title” font family in the Passionate Pro customizer.

    It loaded any font I select from fonts.gstatic.com…

    P.S. I’m fine with my workaround, as we’re not using Roboto anymore on the live site and everything is working as expected.

    Plugin Author Danny Cooper

    (@dannycooper)

    I have only tested the free version, so the Pro theme might be different. If you want me to look into it further you can send the files to team@fontsplugin.com

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.