Support » Fixing WordPress » Parts of Dashboard don't work

  • I need some help please. I’ve been going round and round with my web host (WebIntellects). It’s been one thing after another.

    I just added WordPress to one of my sites and I’m having all sorts of trouble in the Dashboard: I can’t edit posts, I can’t create a new post (I can edit a post’s title, but I can’t edit the post itself), I can’t upload media and I can’t delete the background image file via the Dashboard.

    Anyway I have two domains from this web host: WebIntellects.

    They tell me they are running:

    SITE ONE (the site I’m currently trying to use):
    PHP 5.2.17 (cli) (built: Jan 7 2011 08:49:48)
    mysql Ver 14.12 Distrib 5.0.77

    PHP 5.2.12 (cli) (built: Dec 17 2009 22:30:32)
    mysql Ver 14.12 Distrib 5.0.90

    As I understand it that should be compatible with the latest version of WordPress right?

    The requirements to run WordPress:
    PHP version 5.2.4 or greater
    MySQL version 5.0 or greater

    I haven’t worked in SITE TWO for awhile but SITE ONE is currently giving me trouble.

    In addition to the problems I listed above, the “Live Preview” theme function doesn’t work. It loads the column on the left but the theme preview itself doesn’t load. It’s just a white screen. The browser display bar says the the page is fully loaded.

    I’ve tried this and the other problems on Chrome, Safari and Firefox, on a Mac running Mountain Lion.

    All of these are problems within the Dashboard so I can’t post a link so you can see them. The “live” page itself just looks like WordPress when you first install it, but with a specific theme in place.

    That led me to wonder if there’s a permissions problem. But I can’t imagine how the permissions could have gotten messed up. I’ve run WordPress before on this web host and not needed to change permissions. And I don’t think the permissions theory explains everything.

    Anyone here have a better idea of where I should start troubleshooting?

    The problem may just be the web host. I really want to change web hosts but the I only just got back to using WordPress (I just finishing moving to a new city), and I pay my web host via an auto pay set up, that just renewed. So I’m not sure I can move my site to anther host. But I’ve had so much trouble with my web host it may be worth a little extra trouble to be rid of them.

    Anyway, thanks for any advice.

Viewing 8 replies - 1 through 8 (of 8 total)
  • As I understand it that should be compatible with the latest version of WordPress right?

    Both hosting accounts should be suitable for WordPress based on the info you provided. Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    Still no good. I have no idea what is wrong.

    First, I deleted any additional theme from the FTP and switch to Twenty Eleven. But I still have all the same problems, I can’t view the theme previews etc. However while fiddling with it I discovered I can edit in white:

    A screenshot of the Post section of the Dashboard. The text is in white on a white background and the only way to read it is to highlight it. Otherwise it looks like this. And it won’t let me click on the HTML tab or the upload media tab in those screenshots either.

    So I decided to try reinstalling WordPress. From my web host’s file manager I deleted all the WordPress files (after I had saved a copy of wp-config.php). Then I uploaded a fresh download of WordPress. The only file that is the same is my wp-config.php. I even deleted wp-content because I have no content on this site to lose.

    However, I’m not sure how, given I deleted all the file before re-uploading WordPress, but the type I added in white (in the screen shot above) is still there:

    I even cleared my cache just to be sure, but it’s still there. So should I try reinstalling WordPress again?

    So, either I’ve still got some old file in there messing it up, or there’s something wrong with wp-config.php, or it’s all my web host’s fault. I have no idea what is wrong.

    But I have never had this much trouble installing WordPress. Oy!

    Do you have any installed plugins?


    I only just installed WordPress on this site so I have added nothing.

    Just to rule things out:

    I do have all the files in the main directory, rather than put the WordPress files in a sub directory and that would then run from the main site.

    i.e.: I’m NOT doing this:
    WordPress files here:
    Site here:

    This is what I’m doing:
    WordPress files here:
    Site here:

    Have you had a look at each site’s error log for clues?

    You mean like in firebug?

    No. These are logs produced by your server. Try asking your hosts for access to your site’s error logs.

    I finally got the error logs

    I can only access the back in of my website via wifi. my ISP and my web host refuse to get along, I’m still working on this; it never ends.

    Anyway. Here’s the error I’m getting the most:

    “RSA server certificate wildcard CommonName (CN) `*’ does NOT match server name!?”

    So I used that language to search through the codex and the forums and I found this thread.

    I don’t understand what is meant by “777” in that thread.

    But I did go into my file manager and currently my WordPress files are in httpdocs. And the permissions of it are: “rwx r-x —” Listed as:

    —–Read mode–Write mode–Execute/search mode

    What should they be?

    I also checked as that thread advised:

    In WP Admin – go to the Permalinks settings and check if it says anything about not being able to write to .htaccess.

    I’m not seeing anything there about that.

    I also checked out this support thread.

    I went into the Admin and into Settings > General and my site URL and WordPress URL are correct.

    I did find a few things in my search of this formum about a “htaccess” file. But so far I’m not finding one of my site. Where should I be looking?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Parts of Dashboard don't work’ is closed to new replies.