WordPress.org

Support

Support » Themes and Templates » Part of my old CSS doesn’t work

Part of my old CSS doesn’t work

  • In 1.1 and 1.2, I used the following code to put a box around each comment:

    ul#commentlist li {

    border-left: solid 1px #999999;
    border-right: solid 1px #999999;
    border-top: solid 1px #999999;
    border-bottom: solid 1px #999999;
    padding-left:8px;
    padding-right:8px;
    padding-top:8px;
    padding-bottom:8px;
    margin: 20px;
    color:#333333; <———change#1
    }

    #commentlist p {
    color:#fff; <———–change#2
    }

    Now it doesn’t work anymore. Can anyone offer a modded version that will work with 1.5?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Is the “commentlist” name still the same in the new theme you are using?

    the color selector changes the color of the font and not the color of anything else. If you want the color of the box to change, you change the #999999 in the box selectors above. Is this what you are having trouble with, or is the box itself not showing up? Then check to make sure the “commentlist” is the same in the theme you’ve chosen. It might be called something else.

    Syd,
    Save yourself some typing, dude!

    ul#commentlist li {
    border: 1px solid #999;
    padding: 8px;
    margin: 20px;
    color: #333;

    this is the short version of your above CSS. Much cleaner and easier to maintain.

    Very true, but do realize that older browsers still don’t recognize the shorthand. I say, “LET THEM UPGRADE, THE BACKSLIDERS”, but some people like to think of these slow folks once in a while. Nothing wrong with it, but yes, it’s much easier.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Part of my old CSS doesn’t work’ is closed to new replies.
Skip to toolbar