WordPress.org

Forums

Parsing error - GoDaddy install (4 posts)

  1. sodafizz
    Member
    Posted 10 years ago #

    My hosting is via Godaddy. I have uploaded the WP files into a top-level directory called ‘wordpress’.

    Upon trying to launch http://featuringdave.com/wordpress/wp-admin/install.php, I receive: “Parse error: parse error, unexpected T_STRING in /home/content/s/o/d/sodafizz/html/wordpress/wp-config.php on line 13�

    Here are my settings in wp-config:

    // ** MySQL settings ** //
    define('DB_NAME', 'logicalmeme'); // The name of the database
    define('DB_USER', 'logicalmeme'); // Your MySQL username
    define('DB_PASSWORD', 'mypassword'); // ...and password
    define('DB_HOST', 'mysql13.secureserver.net'); // 99% chance you won't need to change this value

    Apparently, GoDaddy is one of the 1% of hosts where you cannot use ‘localhost’. (See http://wordpress.org/support/topic.php?id=28754)

    I have my real password below instead of ‘mypassword’.

    Any ideas? Below are the full contents of my wpconfig file:

    <?php
    // ** MySQL settings ** //

    define('DB_NAME', 'logicalmeme'); // The name of the database

    define('DB_USER', 'logicalmeme'); // Your MySQL username

    define('DB_PASSWORD', '******’); // ...and password

    define('DB_HOST', 'mysql13.secureserver.net'); // 99% chance you won't need to change this value

    //
    Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_';
    // example: 'wp_' or 'b2' or 'mylogin_'

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* Stop editing */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

  2. Mark (podz)
    Support Maven
    Posted 10 years ago #

    WPLANG to 'de'

    Delete that line.
    The // denotes a comment, and because it has wrapped, the code thinks that line is something important.

  3. sodafizz
    Member
    Posted 10 years ago #

    Didn't work. When I open my wp-config in Notepad, it is not 'wrapped' like I posted above, but rather is jammed into only a few consecutive lines (with little squares as characters that appear to divide chunks). Should I perhaps re-align the wp-config contents to be like I posted above?

  4. sodafizz
    Member
    Posted 10 years ago #

    I fixed it! What I did was to eliminate all extraneous code and characters in wp-config, leaving only the following:

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'logicalmeme');
    define('DB_USER', 'logicalmeme');
    define('DB_PASSWORD', '*****');
    define('DB_HOST', 'mysql13.secureserver.net');
    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.