• Resolved jkwp

    (@jkwp)


    While working on an article, I encountered the following problem today which might be a result of the parsing error in the third message below:

    Warning: session_start() [function.session-start]: open(/tmp/sess_0b3fd19e5d4de1ef17aa0d1040b52380, O_RDWR) failed: Permission denied (13) in /mysite/wp-content/plugins/akeebabackupcore/helpers/AkeebaBackupWP.php on line 43

    Warning: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent (output started at /mysite/wp-content/plugins/akeebabackupcore/helpers/AkeebaBackupWP.php:43) in /mysite/wp-content/plugins/akeebabackupcore/helpers/AkeebaBackupWP.php on line 43

    Parse error: syntax error, unexpected T_STATIC in /mysite/wp-content/plugins/piwik-tracking-by-mente-binaria/models/options.class.php on line 95

    Warning: Unknown: open(/tmp/sess_0b3fd19e5d4de1ef17aa0d1040b52380, O_RDWR) failed: Permission denied (13) in Unknown on line 0

    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0
    ————————–
    Afterwards I was unable to display anything in wp-admin. My initial workaround was to disable the file options.class.php via ftp access, which gave me access to the wp-dashboard again. Thereafter I encountered the message with the parsing error in line 95 once more. So I disabled the plugin in the dashboard.

    Is there a typo in line 95 or is it possibly a conflict with Akeeba Backup?

    https://wordpress.org/plugins/piwik-tracking-by-mente-binaria/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi, JKWP,

    Thank you for taking the time to report this. I will look into it as soon as possible.
    Meanwhile, can you please tell me which version of WordPress you are using?

    Regards,
    Sergio S.

    Meanwhile, can you please tell me which version of WordPress you are using?

    Happened with WP 3.9.1 (also shown on the right side of this page 🙂
    The site is running with php 5.3

    Oops, thanks for pointing that out. 🙂

    I’m puzzled. That error should only occur with versions of PHP older than 5.3.
    Can you try to replace all occurrences of “static::” on options.class.php, with “self::”?

    I’m puzzled. That error should only occur with versions of PHP older than 5.3

    Maybe that was the issue. I rechecked the php version in use. The server provides php 5.2 by default, but allows to load php 5.3 via a .htaccess file, which I’m using. When I checked it, for some reason the content of the .htaccess file was deleted.

    At present I don’t have an idea how this happened.

    Can you try to replace all occurrences of “static::” on options.class.php, with “self::”?

    I didn’t try this yet. First thing I did was to rebuild the .htaccess file and after doing that, the site seems to work normal again. Will let you know if the issue shows up again.

    Since you haven’t said anything else, i assume the problem has been solved, so i am going to mark this as resolved.

    If you still have an issue, though, please let me know.

    Yes, it’s solved. I had the same problem again last week and in both cases it was due to loss of a htaccess file which instructs the server to load php 5.3 instead of the server’s default php 5.2.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Parsing error’ is closed to new replies.