Support » Plugin: Registrations for WooCommerce » Parsing error?

  • Resolved hornets08

    (@hornets08)


    Hello,

    Really interested in getting this plugin installed for my website. I can install this plugin without any issue.

    However, when trying to activate it, it throws the following fatal error: ” Parse error: syntax error, unexpected ‘[‘ in /home/dnp/public_html/wp/wp-content/plugins/registrations-for-woocommerce/classes/class-wc-registrations-checkout.php on line 140″

    I have tried deactivating all plugins except for Woocommerce. No luck. Any quick fixes to this?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Allyson Souza

    (@allysonsouza)

    Hi @hornets08,

    What is the version of your PHP? This sounds like a problem with the array declaration method used, $users = [];, this short version was implemented in PHP 5.4 (WordPress requires/suggest PHP 5.6+)

    Thanks! This is exactly what it was. Unfortunately, I will have to wait this plugin until I can officially upgrade my php version. Thanks again!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Parsing error?’ is closed to new replies.