Support » Fixing WordPress » parse error with wp-config.php

  • I have several wp installs as add on sites on one domain and they all now give me (Parse error: syntax error, unexpected ‘<‘ in /home/andreb01/public_html/properties/wp-config.php on line 91) and I can’t access admin or site from browser. I didn’t make any changes resently and last I checked they were all up fine.
    Any Ideas whats causing this?
    Thanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • esmi

    (@esmi)

    Forum Moderator

    Have you tried re-uploading fresh copies of the wp-config.php files?

    No I haven’t but I’ll try it.
    Thanks.

    I just realised, I don’t know how to proceed. Do I get a new config files and change the data base info or just upload a new config file?
    I can istall wp with Fantastico and that’s about it. Maybe I’m in over my head.

    esmi

    (@esmi)

    Forum Moderator

    Download a copy of your current version of WordPress to your computer. Open the archive and extract the wp-config-sample.php file. For each site, open the file in a plain text editor, add the database connection details required and save the amended file as wp-config.php.

    Next, FTP into your site (or use whatever file management application your host provides) and rename the existing wp-config.php file on the server for each site to wp-config-old.php. Then upload your newly saved version.

    After uploading a new config file,
    Parse error: syntax error, unexpected $end in /home/andreb01/public_html/cherrythighs.com/wp-config.php on line 1
    This is the new Parse error I received when trying to view in my browser.
    I wish I knew more about coding!!

    esmi

    (@esmi)

    Forum Moderator

    Looks like you removed something you shouldn’t have in wp-config.php. Perhaps the opening <?php statement on the first line?

    I checked two different sites and they have the same problem. The <?php is there.

    esmi

    (@esmi)

    Forum Moderator

    Well, something is missing at the top of the wp-config.php files. Try re-creating them again and this time be very careful not to delete any punctuation such as semi-colons or single quotes.

    I have Parse error: syntax error, unexpected ‘<‘ in /wp-config.php on line 91.
    this has happened several times. I have tried deleting the theme and starting from scratch, put in some content and it works fine for a couple days then back to this error again.
    Is this a hack?
    I would like to show line 91 but it is too large to place here.
    Can anyone help?

    Here I am again. I tried to change the website location in my themes options in admin mode and, Got Parse error: syntax error, unexpected ‘}’ in /home/andreb01/public_html/nationalface.com/nationalface.com/wp-content/themes/ConservativeAmericanWP/functions.php on line 61.
    If I post the contents of that line can someone debug it?
    Can Dream Weaver correct such problems as this?

    Hi again,
    can someone look at this wp theme and find out why it keeps doing this. I really would like to keep this design but it’s never completely functional.
    Has anyone else used this theme and had problems?
    Thanks.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘parse error with wp-config.php’ is closed to new replies.