Support » Theme: Pixova Lite » PARSE ERROR / T_STATIC

  • Resolved ellehwz

    (@ellehwz)



    Hi there – trying to install the Pixova Lite theme and I keep getting the error msg “Parse error: syntax error, unexpected T_STATIC in wp-content/themes/pixova-lite/inc/components/related-posts/class.mt-related-posts.php on line 72

    Can anyone help determine why I’m getting this error, and how to fix it?

    Thank you!!!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi ellhwz,

    that issue is related to your PHP version. Please check with your hosting company and make sure you are running at least 5.4.42.

    Thanks,
    Cristian.

    Thought it might be that, I checked and they’re only running 5.2, I can upgrade to at most 5.3 with them. Booo. I’ve sent them a requires to upgrade to more recent versions!!!!!!

    Thanks for the response!

    No problemo.

    Hi there, any idea how to roll back?
    I would prefer not upgrading to latest php version for now.
    Many Thanks

    Ion Rutz

    (@ionrutz_machothemes)

    Macho Themes Support

    Hello @capucinemoreaux,

    You should take this issue to your server provider, there’s not much I can do about it.

    Pixova Lite cannot function on pre-version 5.4.24 and for security issues, I’d recommend going with anything newer than that, considering PHP has reached v7

    Regards

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘PARSE ERROR / T_STATIC’ is closed to new replies.