Support » Fixing WordPress » Parse error: syntax error, unexpected ‘ ‘ (T_STRING) i

  • Parse error: syntax error, unexpected ‘ ‘ (T_STRING) in /home/customer/www/kaihaoind.com/public_html/product/wp-config.php on line 2

    how to solve this problem?

    • This topic was modified 5 months, 2 weeks ago by Jan Dembowski. Reason: Moved to Fixing WordPress, this is not a Requests and Feedback topic
Viewing 5 replies - 16 through 20 (of 20 total)
  • Thread Starter chrisfang

    (@chrisfang)

    @fierevere YUI you know how it can be solved?

    Sorry to jump on this thread I just got this error today.

    Parse error: syntax error, unexpected T_STRING, expecting T_CONSTANT_ENCAPSED_STRING or ‘(‘ in /clientdata/zeus-dynamic-1/s/y/sydneyosteopathy.com.au/www/wp-content/plugins/gravityforms/gravityforms.php on line 32

    Due to this I can no longer log in to my webpage editor through wp-admin and the page no longer displays.

    All I get is the above error. When I try to log in through wordpress it says my password is wrong yet it worked on the wp-admin before the crash.

    I had updated a couple of plug ins – particularly ‘gravityforms’ which I’m assuming wrecked everything.

    I could really use help here as I run a health care business and patients book through that webpage. I’ve had to move the domain to an old webpage from wix but this is still going to take 48 hours to shift over.

    Hi @dantheosteo, I’ll answer here as I believe @chrisfang has started a new thread in the Woocommerce forums. However, please start a new thread in the future.

    It definitely sounds like the update to Gravity Forms has caused an issue. You should be able to deactivate the plugin by manually resetting your plugins (no Dashboard access required).

    I’ve also found the following page from Gravity Forms, which suggests this error is because you’re running an older version of PHP: https://docs.gravityforms.com/unexpected-t-string-php-error/

    You may need to check with your web host if you’re not sure which version of PHP you’re using.

    Hope this helps!

    (@chrisfang – If you’re still having issues you may want to check your version of PHP as well. It could be a similar issue.)

    Thread Starter chrisfang

    (@chrisfang)

    @mikachan thank you very much for your help.
    it works now.once i updated to the new version of wordpress.
    thanks again.
    have a good day.
    @dantheosteo try update the version.

    @chrisfang Awesome! Glad you got it working. Thanks for letting me know.

Viewing 5 replies - 16 through 20 (of 20 total)
  • You must be logged in to reply to this topic.