Support » Plugin: Postman SMTP Mailer/Email Log » Parse error: syntax error, unexpected T_STRING

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Author Jason Hendriks

    (@jasonhendriks)

    Hi Kaorw. That seems to be a multisite error. I haven’t written the plugin to accommodate for WPMU, but if you’re willing to help me test I can install WPMU on my end and make the necessary changes.

    Sure, What can I do for you?

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Hi Kaorw. Well I installed WPMU on my computer and put the plugin on and I can’t find a problem. So I don’t think it’s related to you being on a WordPress network.

    Line 13 in postmap.php is

    namespace Postman {

    ..so now I think that you have run into this error because you are running with a PHP version older than 5.3 (PHP 5.3 was released in June 2009).

    Can you tell me the version of PHP you are running? Here’s a plugin to do it if you’re not sure how to do it manually. Can you tell me where your site is hosted? Do you do it yourself?

    based on phpinfo

    I’m running PHP ver 5.2.5 with Apache 2.0 handler

    here’s phpinfo page of my hosting

    http://www.kaorw.net/phpinfo.php

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    ok, give me a few days and i’ll make a version without the namespace..

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Give v0.2.5 a try. I’ve received the namespace from the code.

    If you have previously created a Client ID, delete it and create a new one.

    heres some feedback.

    I updated to 0.2.5 .

    There are no more error msg when activation.

    – In dashboard, information alret msg “Postman SMTP is activated, but not intercepting mail requests. Configure and Authorize the plugin” have no link address. In source view, html codes are like below.

    <div class="update-nag"><p>Postman SMTP is activated, but <em>not</em> intercepting mail requests. <a href="%s">Configure and Authorize</a> the plugin.</p></div><div class="wrap">

    – After paste Client ID and Client Secret, Save change and request permission works correctly.

    – Send Test mail return with error below

    Fatal error: Call to undefined function str_getcsv() in /free/home/kaorwnet/html/wp-content/plugins/postman-smtp/Postman/OAuthSmtpEngine.php on line 111

    – Delete All Data comes with error too.

    Warning: Missing argument 2 for update_option(), called in /free/home/kaorwnet/html/wp-content/plugins/postman-smtp/Postman/AdminController.php on line 173 and defined in /free/home/kaorwnet/html/wp-includes/option.php on line 229
    
    Warning: Cannot modify header information - headers already sent by (output started at /free/home/kaorwnet/html/wp-includes/option.php:229) in /free/home/kaorwnet/html/wp-includes/pluggable.php on line 1178
    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Configure and Authorize the plugin” have no link address => Fixed
    Fatal error: Call to undefined function str_getcsv() => Replaced with PHP 4 function
    Warning: Missing argument 2 for update_option() => Fixed

    Before I release a new version, would you please grab the development version and try it out.

    Sorry about the trial-and-error, I don’t have your version of PHP working on a web server (yet).

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    I found this page that says Zend Framework 2.3 requires PHP 5.3.23 or above.

    I’ve installed PH 5.2.17 on my computer but it’s probably going to be a little while longer until I get a working version for your version of PHP..

    I can’t find any more error msg on latest update.

    Saddly.. after configure OAuth Setting and request permission process

    Test mail process failed with message below

    “Oh, bother! … Network is unreachable”

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Oh no 🙁 after all that!!!

    Can you test if port 465 is open?

    Like this:

    Jasons-MBP:~ jasonhendriks$ telnet smtp.gmail.com 465
    Trying 173.194.76.108...
    Connected to gmail-smtp-msa.l.google.com.
    Escape character is '^]'.

    It will say ‘Connected’ if successful.

    [kaorwnet@freekr2 ~]$ telnet smtp.gmail.com 465
    Trying 74.125.203.109…
    telnet: connect to address 74.125.203.109: Connection refused
    Trying 74.125.203.108…
    telnet: connect to address 74.125.203.108: Connection refused
    Trying 2404:6800:4008:c02::6c…
    telnet: connect to address 2404:6800:4008:c02::6c: Network is unreachable
    telnet: Unable to connect to remote host: Network is unreachable
    [kaorwnet@freekr2 ~]$

    is this result mean 465 port is close?

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Unfortunately, yes. You will need to contact your host provider for a solution. If they can’t help you, you can always move your WordPress to site to http://www.openshift.com.. they give you three WordPress sites for free.

    Thanks for cool solution.

    I signup and using openshift for several hours and realize I can’t access my storage by ftp.

    I’m not familiar with git ways. Can I do everything that I can with ftp in git as well?

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    GIT is a source control system.. The idea behind source control is that every developer in a project can make changes to the code in a repository, and changes can be undone if needed. The source code repository keeps track of every change ever made.

    In the case of OpenShift.. the source code IS your WordPress application. So on your computer you install wordpress, add it to your GIT repository, and then sync that repository to OpenShift and *poof* your files upload, the server is restarted, and WordPress runs.

    If that appeals to you, then you want to create a PHP cartridge, add a MySql cartridge to it, and then clone the GIT repository to your local computer and unzip WordPress there, then push to the server. It’s for advanced users I would say.. definitely developers.

    An easier way to use WordPress there is to just create a WordPress cartridge, and it is magically installed for you. But as far as I am aware, you CANNOT access any files with GIT if you do it this way.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Parse error: syntax error, unexpected T_STRING’ is closed to new replies.