Support » Plugin: WP Super Cache » Parse error: syntax error, unexpected T_FUNCTION

  • Today 19.07.2017 at 23:55 after update the plugin to the last version I have this error:
    Parse error: syntax error, unexpected T_FUNCTION in /wp-content/plugins/wp-super-cache/rest/load.php on line 144
    How can I fix the problem?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Donncha O Caoimh

    (@donncha)

    What version of WordPress are you using? Please upgrade to 4.8 as that should fix the problem.

    Hi Donncha,

    I posted this on another thread, but I wanted to include it here.

    I think that those who administer updates via the update-core.php page find suddenly that they can no longer access any page at all including admin pages. And now have to troubleshoot things via FTP or something. There are many many admins who know how to do one but not the other. (I’m one of them. My site was down for nearly an hour)

    It should not be possible to upgrade the WPSC plugin when the WP prerequisite is not present. I think you’re going to have a busy time answering these forum topics until you pull 1.5.0 and find a way to roll it out safely.

    Hi,

    WPCS 1.5.0 seems to require PHP 5.3.0 and up because it uses an anonymous function and __DIR__ magic constant.

    At least, it’s not compatible with “Requires WordPress Version: 3.0”.

    Plugin Author Donncha O Caoimh

    (@donncha)

    This has been fixed in 1.5.1. Thanks for the feedback.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Parse error: syntax error, unexpected T_FUNCTION’ is closed to new replies.