Support » Plugin: Shariff Wrapper » Parse error: syntax error, unexpected '}' … on line 102

  • Resolved bladecgn

    (@bladecgn)


    Ich bekomme, wernn ich das plugin aktivieren mΓΆchte immer:
    Parse error: syntax error, unexpected ‘}’ in D:\wamp\www\wordpress\wp-content\plugins\shariff\shariff.php on line 102

    Benutze MySql 5.6.12 und PHP 5.5.12

    Habe auch schon das Theme auf Standard gesetzt und alle anderen Plugins deaktiviert, hilft leider nicht.

    Hatte in einem anderen Forum gesehen dass noch jemand das Problem hat.

    https://wordpress.org/plugins/shariff/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Ich habe das gleiche Problem!

    Plugin Author 3UU

    (@3uu)

    Ich gehe davon aus, Du hast es zum ersten Mal versucht zu aktivieren? Ist also kein Problem, was erst durchs Update heute Nacht entstanden ist? Sieht naemlich an der Code-Stelle so aus, als waere es ein Problem von PHP, dass es den langen Tage <?PHP nicht erkennt. Noch eine Frage. Der Pfad da oben sieht so aus, als wuerdest Du das Windows-Binary von PHP verwenden. Richtig?

    Plugin Author 3UU

    (@3uu)

    Testet man einer von Euch bitte mit der neuen Version 1.4. Ich habe leider gerade keine WAMPe zum Probieren.

    Vielen Dank!

    Habe auf dem Wampserver die neue Version instaliert. Wenn ich es starte kommt kein fatal error, stattdessen sehe ich (denke ich) einen Teil des Quellcodes: vertical.’, ‘shariff3UU’ ), ‘shariff3UU_checkbox_vertical_render’, ‘pluginPage’, ‘shariff3UU_pluginPage_section’ ); add_settings_field( ‘shariff3UU_text_services’, __( ‘Put in the service do you want enable (facebook|twitter|googleplus|whatsapp|mail|print|pinterest|linkedin|xing|reddit|stumbleupon|info). Use the pipe sign | between two or more services.’, ‘shariff3UU’ ), ‘shariff3UU_text_services_render’, ‘pluginPage’, ‘shariff3UU_pluginPage_section’ ); add_settings_field( ‘shariff3UU_checkbox_backend’, __( ‘Check this to show share statistic.’, ‘shariff3UU’ ), ‘shariff3UU_checkbox_backend_render’, ‘pluginPage’, ‘shariff3UU_pluginPage_section’ ); add_settings_field( ‘shariff3UU_text_info_url’, __( ‘Change the default link of the “info” button to:’, ‘shariff3UU’ ), ‘shariff3UU_text_info_url_render’, ‘plug

    Plugin Author 3UU

    (@3uu)

    Ah, das sieht jetzt so aus, als ob der Server die PHP-Shorttags nicht verarbeitet. Is in der Tat der Quelltext, was Du da angezeigt bekommst. Kannst Du bitte mal in Deiner php.ini die Option

    short_open_tag = "1"

    setzen. Dann neu starten. Kann sein, Du bekommst dann wieder die eingangs genannte Fehlermeldung. Waere dann trotzdem nochmal gut zu wissen, an welcher Zeile.

    Solltest Du weiterhin den PHP-Code sehen, dann pack mal ein kleines Skrpt auf Deinen Server mit

    <? phpinfo() ?>

    beziehungsweise

    <?PHP phpinfo() ?>

    und schau mal, ob short_open_tag wirklich auf “On” steht.

    BTW: Wo bekommt man eigentlich dieses WAMP her, dass Du nutzt? Sorry, bin in der Windoof-Welt nicht ganz so bewandert πŸ™‚

    Hallo,

    ich habe vorgestern das Plugin aktualisiert und aktiviert – daraufhin ist meine Seite komplett “auseinander gefallen”, ich sah den Quelltext auf jeder einzelnen Seite, sowohl im Backend als auch im Frontend.

    Ich musste das Plugin manuell ΓΌber FTP entfernen. :/

    Plugin Author 3UU

    (@3uu)

    Wow, das ist echt ein “spannender Effekt”. Tut mir echt leid fuer Dich. Aber WP ist eigentlich ziemlich robust gegen solche Effekte. Zumindest, wenn PHP nicht allzu seltsam konfiguriert wurde. Wie auch immer, zur Ursachenforschung brauche ich was mehr Informationen. Erstmal waere gut zu wissen, was phpinfo() zu short_open_tag sagt. Ausserdem waere wirklich sehr hilfreich, wenn Du mir verraten koenntest, von welcher Version Du upgradet hast. Sonst ist Fehlersuche echt stochern im Nebel πŸ˜‰

    Hallo,

    ich hatte vor dem Update die Version 1.4.0.

    short_open_tag ist laut phpinfo() “off”.

    MfG

    Plugin Author 3UU

    (@3uu)

    Ah, okay, dann weiss ziemlich sicher, welche Aenderung das Problem verursacht hat. Ich kann es nur leider nicht testen πŸ™ Zumindest nicht, wenn es ein WAMP sein sollte. Bevor ich jetzt die geaenderte Version committe, kannst Du mir vielleicht noch sagen, ob das die Standard-Einstellung bei Deiner Distribution ist. Und vor allem, welche Du ueberhaupt verwendest? πŸ˜‰ Ich wuerde mir ggf. dann einfach eine entsprechenden Testumgebung mit aufsetzen koennen.

    Plugin Author 3UU

    (@3uu)

    Soo, ich habe gerade eh eine kleine Erweiterung committet und bei der Gelegenheit auch gleich mal den Code insgesamt was aufgeraeumt. Was ich als Stolpersteine fuer WAMPs vermute, ist raus. Aber eben ungetestet unter Windoof. Waere wirklich nett, wenn mir mal jemand verraten koennte, was da so die verbreitetste Distribution ist. Oder schreibt mir einfach rein, was ihr gerade so nutzt. Sonst uebersetze ich mir selber nen PHP-Binary fuer Windoof. Hab ich im vorigen Jahrtausend mal gemacht. War grauenvoll. Nee, ich lass das mal lieber. Auf meinen LAMPen laeuft es prima. Aber das war ja vorher schon so. Vielleicht gibt sich mal jemand nen Ruck und testet die Version 1.4.2 jetzt unter WAMP. Bitte nicht auf nem Produktions-System, wenn ihr keinen alternativen Zugriff aufs Dateisystem habt, um das Plugin notfalls loeschen zu koennen! Oder erst am Montag, wenn Euer Hostmaster wieder aus dem Wochenende ist πŸ˜‰

    Hallo!

    Es scheint jetzt zu funktionieren!

    Vielen Dank πŸ™‚

    Plugin Author 3UU

    (@3uu)

    Gern geschehen! πŸ™‚ Vielleicht magst ja einen kleinen Review unet https://wordpress.org/support/view/plugin-reviews/shariff?filter=5 machen?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Parse error: syntax error, unexpected '}' … on line 102’ is closed to new replies.