Support » Plugin: Directorist - Business Directory Plugin » Parse error: syntax error, unexpected ‘[‘ in /home/xxx/public_html/wp-content/pl

  • Resolved threepurpleroses

    (@threepurpleroses)


    I cannot activate my plugin, it comes up with this parse error.

    Parse error: syntax error, unexpected ‘[‘ in /home/xxx/public_html/wp-content/plugins/directorist/includes/review-rating/class-review-rating.php on line 81

    This is on a cpanel site.
    It is on a fresh instance of wordpress, so there should not be any incompatibility.
    I also had to get my webhost to up my upload amount in php.ini in order to upload this plugin.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author aazztech

    (@aazztech)

    Hello,

    Thank you very much for using the Directorist plugin.

    This plugin requires PHP version 5.4 or greater. But your hosting is using EXTREMELY OLD and INSECURE version of PHP which is less than 5.4. This is why this parse error was shown.

    Your hosting provider can upgrade your PHP version very easily without any fee if you just ask them to do it.

    WordPress itself recommends using PHP 7.2. Therefore, we also recommend PHP 7.2 if your hosting provider can support it. You will get 100% security and minimum 3-5 times more speed with this latest version of the PHP.

    Here is a friendly message that you can send to your hosting provider.
    ===================
    I’m interested in running the open-source WordPress <https://wordpress.org/&gt; web software and I was wondering if my account supported the following:

    PHP 7.2 or greater
    MySQL 5.6 or greater OR MariaDB 10.0 or greater
    Nginx or Apache with the mod_rewrite module
    HTTPS support
    ===================

    For more information about recommended requirement of running a secure WordPress Site, you can visit the following URL.
    https://wordpress.org/about/requirements/

    We hope it helps. Thank you very much for your patience. If you need any help, feel free to ask us anytime.

    threepurpleroses

    (@threepurpleroses)

    This is my php version – Current PHP version: 7.2. I am already running it on the site. So, there must be something else wrong.
    I appreciate your help.

    threepurpleroses

    (@threepurpleroses)

    oops! I’m bad. Was on the wrong website. I went it and changed it to 7.2. Will let you know if it worked later. Have to get to work.

    threepurpleroses

    (@threepurpleroses)

    works like a charm thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.