Support » Installing WordPress » Parse error: syntax error, unexpected $end…

  • I followed the instructions for upgrading 1.2.1 to 1.5 (I backed everything up locally, deleted everything except wp-config.php, then uploaded the new files…)

    When I try to run upgrade.php, I get the following error:

    Parse error: syntax error, unexpected $end in E:\webs\\wwwroot\wp-includes\wp-db.php on line 309

    Any ideas?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Got it…I delted everything (again) and re-uploaded. Worked fine this time. I guess something got jacked up when I FTP’s the first time…

    “Parse error: syntax error, unexpected $end in /home/.bangle/jzd3/ on line 304”
    is the error I get when I either
    – try to access my intended new location for a previously working blog (theme modified In-Business)
    – try to login or administer either the old or new location.

    The old location is still functional and I have local copies of it and of the default setup for the new location (both locations are directories on the same server, the original had been set up with the wrong name).

    I was using Safari to follow the instructions at – the first option, moving WordPress within your site (changing the URI).

    at “6. Click Update Options” Safari got stuck bouncing back and forth between the old and new directories (repeated and irresoluble redirects), so I was not really able to do “7. Logout of your blog.”, and in effect may have violated “i. (Do not try to open/view your blog now!).”

    I then moved forward with “9. WordPress 2.0 only: Delete the folder wp-content/cache.” and “10. Move your WordPress core files to the new location. This includes the files found within the original directory, such as, and all the sub-directories, to the new location.”

    I moved everything – and I do mean everything – via FTP’ing my local copies from the old directory up to the new one. I’ve done this twice now, with the same result.

    Any suggestions?


    The eventual resolution was resetting wp_options>siteurl to the target directory through phpMyAdmin. I then locally backed up (again) the previously working files from the old directory, emptied the target directory (not entirely sure that was the thing to do), and this time moved the files directly over from one peer directory to the other on the server, using ftp (but not complicating things with a download and upload as I’d done before, which might have corrupted some files or the directory structure).

    After that there was a fair amount of reconfiguring and/or reinstallation of plug-ins, but I was no longer looping when trying to administer the site, or running into a wall of fairly generic error messages. Thanks to the forum for pointing me (in another thread) to the solution.

    Best to all,

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Parse error: syntax error, unexpected $end…’ is closed to new replies.