Support » Plugin: Church Community Builder Core API » Parse error: syntax error, unexpected

  • Resolved gregmattison

    (@gregmattison)


    Hi, we use CCB at our church and am trying to install the Church Community Builder Core API plugin but it’s giving a “Parse error: syntax error, unexpected ‘[‘ in /home3/habaner0/public_html/vcc2/wp-content/plugins/church-community-builder-core-api/ccb-core.php on line 40 error. I can’t activate the plugin as it says fatal error.

    Please help. Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Jared Cobb

    (@jaredcobb)

    Hi Greg,

    Thanks for the heads up about that syntax error! This is a result of the current PHP version that your hosting provider is using. It looks like your provider is still using PHP 5.3 (or older).

    For a few reasons the minimum PHP version required for this plugin is 5.6. The best option is to ask your hosting provider to update to at least 5.6. As an aside, PHP 5.3 reached end of life in August 2014 and hasn’t been receiving security updates since then. It’s a good idea to upgrade for that reason as well.

    I’ll definitely update the plugin so that it doesn’t completely break on activation, so thanks again for letting me know about that!

    Awesome, thank you, that did the trick! updated and now it’s working. Can’t wait to see if I can get the data/content I want out of our CCB right onto our site with your plugin!

    • This reply was modified 1 year, 3 months ago by  gregmattison.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Parse error: syntax error, unexpected’ is closed to new replies.