Support » Plugin: Video Embed & Thumbnail Generator » Parse error: syntax error, unexpected ‘[‘

  • Resolved Chris

    (@web2guru)


    Looks like the recent update broke something. I’m getting this error message:

    Parse error: syntax error, unexpected ‘[‘ in /wp-content/plugins/video-embed-thumbnail-generator/video-embed-thumbnail-generator.php on line 825

    I deleted the plugin folder and the site comes back up. I reinstalled the plugin from the repository and the error came back.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Kyle Gilman

    (@kylegilman)

    Thanks Chris, do you know what version of PHP you’re running?

    Yes, 5.6.31.

    EDIT: Disregard that.

    I didn’t realize this site was still on PHP 5.3.24. It’s a very old GoDaddy plan. I’ll tell my client he’s out of time and we need to migrate.

    Thanks for looking into this Kyle.

    • This reply was modified 8 months, 2 weeks ago by  Chris. Reason: wrong PHP version
    Plugin Author Kyle Gilman

    (@kylegilman)

    It looks like a problem with anything older than version 5.4. I’m going to fix it anyway.

    Plugin Author Kyle Gilman

    (@kylegilman)

    Version 4.6.19 should fix this problem.

    Well thanks for the quick support Kyle! Problem solved! Well done!

    Now to convince my client he still needs to migrate.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Parse error: syntax error, unexpected ‘[‘’ is closed to new replies.