Support » Plugin: Sunny » Parse error: syntax error in Ver.2.0 update

  • Resolved WilliamTai

    (@williamtai)


    Two of my sites got error after update to 2.0.0.

    Parse error: syntax error, unexpected ‘:’, expecting ‘;’ or ‘{‘ in wp-content/plugins/sunny/src/Sunny.php on line 99

Viewing 10 replies - 1 through 10 (of 10 total)
  • jamescockroft

    (@jamescockroft)

    My site is down too.

    Parse error: syntax error, unexpected ‘:’, expecting ‘;’ or ‘{‘ in /home/…/wp-content/plugins/sunny/src/Sunny.php on line 99

    mah2681

    (@mah2681)

    I’m having the exact same error. Caused my site to go down, had to get help to disable the plug-in and rename the folder. Tried reinstalling, same issue. Plug-in worked great until this recent update.

    Here’s my error, meant to add this earlier, it is on line 92 actually:

    PHP Parse error: syntax error, unexpected ‘.’ in /…./wp-content/plugins/sunny/src/Sunny.php on line 92

    • This reply was modified 3 years ago by mah2681. Reason: Added my error
    dwall057

    (@dwall057)

    Likewise, same as William and James

    CPK Web Solutions

    (@cpkwebsolutions)

    Hi

    For anyone who doesn’t know, this can be easily fixed by either deactivating Sunny (delete plugins/sunny folder if necessary), or upgrading to PHP 7.

    FWIW, I move all the sites I can to PHP 7, but there are some very important production sites that are stuck on lower versions due to old unsupported themes and little budget to upgrade.

    Last I checked, WordPress promises to be backwards compatible down to PHP 5.2 or 5.3. Hopefully the Sunny plugin author will reconsider using PHP 7 functionality, as annoying as it might be to miss out on the new stuff!

    Best wishes

    Paul

    benkoo

    (@benkoo)

    Mi site is down. I had to uninstall the plug-in via ftp.

    adinugroho01

    (@adinugroho01)

    Mine too. Thanks for CPK Web Solutions for telling the solution. I’ll try to change it to 7.

    Plugin Author Tang Rufus

    (@tangrufus)

    @cpkwebsolutions is correct.

    Sunny 2.0.0 requires php 7 or later and WordPress 4.7 or later. Please upgrade your servers.

    About backward compatibilities, I have no plan to support php 5 because php 7 makes developing easier.

    The next version will deactivate itself if minimum requirements(php and WordPress version) don’t meet. Until then, ftp to your php 5 server and remove Sunny manually.

    CPK Web Solutions

    (@cpkwebsolutions)

    Hi Tang Rufus

    Understand your position. Ok if I fork the project to provide backwards compatibility?

    Best wishes

    Paul

    Plugin Author Tang Rufus

    (@tangrufus)

    Plugin Author Tang Rufus

    (@tangrufus)

    Starting form Sunny 2.0.1, Sunny checks for php version and deactivate itself if needed.

    Related commit:
    https://github.com/TypistTech/sunny/pull/58

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Parse error: syntax error in Ver.2.0 update’ is closed to new replies.