Support » Plugin: Really Simple Twitter Feed Widget » Parse Error since update

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor whiletrue

    (@whiletrue)

    Hi Tom, starting from the 2.3.1 plugin release (out today) PHP 5.3 is mandatory, because it’s a requirement for the Codebird Twitter Api we use.

    If your PHP version is lower than 5.3 (and you can’t update it on your hosting service), you can download and install the previous 2.3 plugin release.

    Sorry for the uncomfortable situation, we were forced to update the library due to issues for other users.

    I am running PHP 5.3 and running into the same problem…

    I am also running 5.3 and had this error. With all due respect these things should be tested before releasing on a live product. Nearly all of my clients are instructed to install updates if they are rated for their version of wordpress.

    Plugin Contributor whiletrue

    (@whiletrue)

    Hi all,
    sorry for that, the plugin development version worked in all our test environments before releasing it.

    Anyway, a new bugfix release is out now, addressing users with multiple Codebird instances (class_exists check is now namespace safe), if unsure consider the upgrade.

    If the upgrade doesn’t solve your issue, please check and post here the exact PHP version running your site pages (e.g. inserting a temporary echo phpversion(); statement inside your theme footer file) along with the entire error string.

    I have disabled the plugin for now as I was getting the same error:

    unexpected T_STRING in ………./really_simple_twitter_widget.php on line 231
    PHP version 5.2.16

    Same error here. Broke the whole blog. Even admin. Had to restore version 2.3 of the plugin from backup.

    PHP 5.2.17.
    WordPress 3.5.2.
    Really Simple Twitter Widget 2.3.1.1.

    2.3.1.1 works on my stack – 5.3 running with multiple instances – all good in the hood!

    Thanks 🙂

    Just updated to PHP 5.3.26 and it works now.

    whiletrue, you should look into making it backwards compatible (if at all possible), however.

    Yup… went into my host control panel and updated to php 5.3 and works like a charm!

    Plugin Contributor whiletrue

    (@whiletrue)

    Hi all,
    after some night hours the new 2.3.1.2 plugin release is out, adding a compatibility fix for users stuck with PHP < 5.3. Please update and confirm that it fixes the issue on your websites.

    @whiletrue – Thanks for the quick update to your excellent free plugin!
    Nick

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Parse Error since update’ is closed to new replies.