WordPress.org

Support

Support » How-To and Troubleshooting » Parse error Problem

Parse error Problem

  • Justtryingtomakealiving
    Member

    @justtryingtomakealiving

    Hello all

    I seem to be getting the following error in my wp-config folder after I moved website providers (but kept the same domain), went in to change some of the settings so the site would work correctly and now I am getting this error.

    Parse error: syntax error, unexpected ‘*’ in /home/danielem/public_html/wp-config.php on line 17

    My website provider said they have checked the code and it should work, so whats the problem?

Viewing 15 replies - 1 through 15 (of 29 total)
  • Tara
    Volunteer Moderator

    @t-p

    Try:
    – switching to the default theme by renaming your current theme’s folder inside wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides. – resetting the plugins folder by FTP or phpMyAdmin.

    esmi
    Forum Moderator

    @esmi

    What is in line 17?

    Justtryingtomakealiving
    Member

    @justtryingtomakealiving

    According to my hosting provider there was a line in the wp-config.php that needed to be commented out that wasn’t.

    The error is gone, but the site is blank now.

    Any ideas on how to fix this problem too :/

    esmi
    Forum Moderator

    @esmi

    What line?

    Justtryingtomakealiving
    Member

    @justtryingtomakealiving

    It isnt a line thing, the site is gone completely now. All the errors are fixed but its just blank? Could it be a database thing since I moved hosting providers ?

    esmi
    Forum Moderator

    @esmi

    According to my hosting provider there was a line in the wp-config.php that needed to be commented out that wasn’t.

    What line?

    Andrew Nevins
    Forum moderator

    @anevins

    Give us something to go on, please.

    Justtryingtomakealiving
    Member

    @justtryingtomakealiving

    What I have told you, is all I know. Thats all the hosting provider told me. Now that there is no website I am being told it could be a database error, thats what my hosting provider has told me.

    They are advising going into the database in phpmyadmin, and go to the wp-options table, you should see different options you have to edit.

    You would have to edit each path so that it states /home/danielem/public_html/<path_to_file>

    However I am not a pro at this and they wont offer me very much support, I dont even know if this will fix the issue, all I know is that when i go to website (below) , all I get is a blank screen)

    http://www.danielemmerson.net

    Even though once I downloaded all the FTP files from my old hosting provider , then changed the wp-config.php file for the correct information , it is just white???

    Any ideas?

    esmi
    Forum Moderator

    @esmi

    Unless you can give us more to go on, we cannot help. We’re good but we’re not psychic. 😉

    Who are your hosts?

    Justtryingtomakealiving
    Member

    @justtryingtomakealiving

    My previous host was servage.net and my new host is machighway.com

    esmi
    Forum Moderator

    @esmi

    Unless they have a very solid background in WordPress, I would suggest that you take their “advice” with a large pinch of salt. Most hosts do not know a great deal about WordPress.

    What line did your hosts comment out of your wp-config.php file?

    Justtryingtomakealiving
    Member

    @justtryingtomakealiving

    I am not sure, as I do not know very much code.

    Below is the line that originally was causing the issue

    “/* MySQL settings – You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define(‘WP_CACHE’, true); //Added by WP-Cache Manager
    define( ‘WPCACHEHOME’, ‘/home/danielem/public_html/wp-content/plugins/wp-super-cache/’ ); //Added by WP-Cache Manager
    define(‘DB_NAME’, [redacted]);”

    I know it has to do with the above that I posted and I was thinking it had fixed the issue because to begin with i was getting a

    The requested URL “insert url here” was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use

    so then I corrected the issues in wp-config.php file and changed some stuff in the .htaccess file to refresh everything and now I am getting a blank screen as you can see from the link I provided.

    Justtryingtomakealiving
    Member

    @justtryingtomakealiving

    The website http://www.danielemmerson.net should be loading but its just a blank white screen and I get the same screen when I try to login to the wordpress page to edit or anything.

    esmi
    Forum Moderator

    @esmi

    When did you install and activate the caching plugin?

    Justtryingtomakealiving
    Member

    @justtryingtomakealiving

    Sorry?

    I am not understanding what your talking about with ‘ caching plugin’?

    All I did was download all the FTP files from my previous hosting provider ‘ servage’ , changed some of the wordpress documents and reuploaded it to ‘machighway’ as directed. I could check and see if there is a caching plugin? What if I dont have it?

    Any ideas on how to fix the problem?

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Parse error Problem’ is closed to new replies.