Parse error: parse error, unexpected T_STRING (4 posts)

  1. Anonymous
    Posted 11 years ago #

    I'm having issues installing this.
    I have Apache 2.x with Windows XP, PHP [stable and not the beta one], and mysql running
    I download this. I make the config file manually:
    define('DB_NAME', 'whatever'); // The name of the database
    define('DB_USER', 'whatever'); // Your MySQL username
    define('DB_PASSWORD', 'whatever'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    now...with all this in..I remove where it says whatever and remove the ' and put the stuff in. When I do that, I get this:
    Parse error: parse error, unexpected T_STRING in C:\Program Files\Apache2\htdocs\wp-config.php on line 8
    Fatal error: Call to a member function on a non-object in C:\Program Files\Apache2\htdocs\wp-admin\install.php on line 47
    goody...so I put the ' back in there and I end up with this:
    Error establishing a database connection! This probably means that the connection information in youn wp-config.php file is incorrect. Double check it and try again.
    * Are you sure you have the correct user/password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?
    Uhhh...I'm sure its running since I can see it in my system tray. I have apache and php working also just fine. [http://dpvtank.gotdns.org/info.php].
    I'm sure I have mysql running also just fine. I've installed this before [mysql with apache and php] and it has worked fine before. Jut not this time. with this. I figure it might have to do with my firewall. I disable that and it still happens
    Some help here.

  2. southerngal
    Posted 11 years ago #

    You have made a user name, DB and assigned a user to the DB?

  3. Cena
    Posted 11 years ago #

    T-string errors typically mean you've got a quote mark somewhere that's not matched up with another one. (I.e., if you've got one ', you should have 2 (' ') single quote marks.

  4. Anonymous
    Posted 11 years ago #

    I have a username, password, and a database for it all. I'm running this off my computer. So the password is going to be the same. I don't have different accounts running.
    Yup. I have only those signs. I know no double quotes in it at all. All of them are single quote marks, and with that, I'm am..no matter what..getting the error mentioned above.
    I'm still gonna try tinkering around and seeing what happens.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.